summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.10.3.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-07-05 11:18:33 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-06 22:55:02 +0100
commit87b9992ae710cc405b1e4a07a5bfc7a283e80664 (patch)
treecf6c982da619b7992fbc5606d86c98f1c227656b /meta/recipes-devtools/cmake/cmake-native_3.10.3.bb
parent93e9729569963355e2cb5526f9613f117205d1d3 (diff)
downloadpoky-87b9992ae710cc405b1e4a07a5bfc7a283e80664.tar.gz
cmake: Update 3.10.3 -> 3.11.4
This updates CMake to the current stable release and drop many backported patches in the process. (From OE-Core rev: d942ec4ff649782d22afe49fd48839dbbfedc871) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.10.3.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.10.3.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.10.3.bb b/meta/recipes-devtools/cmake/cmake-native_3.10.3.bb
deleted file mode 100644
index e55e8b1cf6..0000000000
--- a/meta/recipes-devtools/cmake/cmake-native_3.10.3.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1require cmake.inc
2inherit native
3
4DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
5
6SRC_URI += "\
7 file://cmlibarchive-disable-ext2fs.patch \
8"
9
10B = "${WORKDIR}/build"
11do_configure[cleandirs] = "${B}"
12
13# Disable ccmake since we don't depend on ncurses
14CMAKE_EXTRACONF = "\
15 -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
16 -DBUILD_CursesDialog=0 \
17 -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
18 -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
19 -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
20 -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
21 -DCMAKE_USE_SYSTEM_LIBRARY_LIBRHASH=0 \
22 -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
23 -DHAVE_SYS_ACL_H=0 \
24"
25
26do_configure () {
27 ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
28}
29
30do_compile() {
31 oe_runmake
32}
33
34do_install() {
35 oe_runmake 'DESTDIR=${D}' install
36}
37
38do_compile[progress] = "percent"