summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.10.2.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-02-15 15:11:16 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:45 +0000
commita63b504f9b7c2a4dbf57637542779e65ad4c1afe (patch)
tree406cdcbc51e529741e8731f2f4fa2fa123593859 /meta/recipes-devtools/cmake/cmake-native_3.10.2.bb
parent4632a4511c8bfd3beea6d3848d876c5c3182fcbf (diff)
downloadpoky-a63b504f9b7c2a4dbf57637542779e65ad4c1afe.tar.gz
cmake: Upgrade 3.10.1 -> 3.10.2
This is a minor stable update to CMake. This includes following changes: ,---- | c1e087a9d CMake 3.10.2 | d592bfc9f Autogen: Ignore not existing source files in cmMakefile | d49986b3b KWIML: Backport RISC-V update to CMake 3.10 | 9417a6d32 FindPostgreSQL: Add support for PG10 | 683e9023a Autogen: Fix for problematic nested list separator | 9b4d31dc7 cmGraphVizWriter: Updated to create and follow dependers for | interface targets `---- (From OE-Core rev: 798dba6fb3e16d3041b01faecfd32c787c142ee8) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.10.2.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.10.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.10.2.bb b/meta/recipes-devtools/cmake/cmake-native_3.10.2.bb
new file mode 100644
index 0000000000..e55e8b1cf6
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.10.2.bb
@@ -0,0 +1,38 @@
1require cmake.inc
2inherit native
3
4DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
5
6SRC_URI += "\
7 file://cmlibarchive-disable-ext2fs.patch \
8"
9
10B = "${WORKDIR}/build"
11do_configure[cleandirs] = "${B}"
12
13# Disable ccmake since we don't depend on ncurses
14CMAKE_EXTRACONF = "\
15 -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
16 -DBUILD_CursesDialog=0 \
17 -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
18 -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
19 -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
20 -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
21 -DCMAKE_USE_SYSTEM_LIBRARY_LIBRHASH=0 \
22 -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
23 -DHAVE_SYS_ACL_H=0 \
24"
25
26do_configure () {
27 ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
28}
29
30do_compile() {
31 oe_runmake
32}
33
34do_install() {
35 oe_runmake 'DESTDIR=${D}' install
36}
37
38do_compile[progress] = "percent"