diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2019-08-30 15:35:30 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-09-06 14:58:09 +0100 |
commit | 35c8b87b1ca2d181e9aa77d83541f29ea76481a2 (patch) | |
tree | 25ddceda74d15076e3adc9c43adc577aedcc9c30 /meta/recipes-devtools/build-compare/build-compare_git.bb | |
parent | 2cd5daffe06b430b33240a99e5dcfd6eb66c8f45 (diff) | |
download | poky-35c8b87b1ca2d181e9aa77d83541f29ea76481a2.tar.gz |
build-compare: 2015.02.10 -> 2019.08.14
* Removed the following patches which are already merged by upstream:
0001-Add-support-for-deb-and-ipk-packaging.patch
Rename-rpm-check.sh-to-pkg-diff.sh.patch
functions.sh-improve-deb-and-ipk-checking.patch
functions.sh-remove-space-at-head.patch
functions.sh-run-rpm-once-to-make-it-faster.patch
pkg-diff.sh-check-for-fifo-named-pipe.patch
pkg-diff.sh-check_single_file-return-at-once-when-sa.patch
pkg-diff.sh-remove-space-in-the-end-for-ftype.patch
* Rebased Ignore-DWARF-sections.patch
This version is very outstanding when compare binary packages, e.g.:
PRSERV_HOST = "localhost:0"
INHERIT += "packagefeed-stability"
PACKAGE_CLASSES = "package_ipk
$ bitbake opkg
$ find tmp/deploy/ipk >/tmp/ipk_1
Add a "bbnote 'hello'" to autotools.bbclass' autotools_do_configure.
* BEFORE the upgrading, the result is:
$ diff /tmp/ipk_1 /tmp/ipk_2 -Nur | diffstat
ipk_2 | 1570 +++++++++++++++++++++++++++++++++---------------------------------
1 file changed, 785 insertions(+), 785 deletions(-)
* AFTER the upgrading, the result is:
$ bitbake opkg
$ find tmp/deploy/ipk >/tmp/ipk_2
$ diff /tmp/ipk_1 /tmp/ipk_2 -Nur
No output
And if we really modifed a recipe such as opkg, then it would show that it is
changed.
For a full world build AFTER the upgrading:
$ diff /tmp/ipk_6 /tmp/ipk_7 -Nur | diffstat
ipk_7 | 2090 +++++++++++++++++++++++++++++++++---------------------------------
1 file changed, 1045 insertions(+), 1045 deletions(-)
There are 10968 packages in totall, 1045 ones have been changed, so we can still
improve it in the future.
(From OE-Core rev: 4c77fdfc0b3b31105a4dfd1a4634f8464b52d933)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/build-compare/build-compare_git.bb')
-rw-r--r-- | meta/recipes-devtools/build-compare/build-compare_git.bb | 12 |
1 files changed, 2 insertions, 10 deletions
diff --git a/meta/recipes-devtools/build-compare/build-compare_git.bb b/meta/recipes-devtools/build-compare/build-compare_git.bb index efcf6b6dd3..b0560cc277 100644 --- a/meta/recipes-devtools/build-compare/build-compare_git.bb +++ b/meta/recipes-devtools/build-compare/build-compare_git.bb | |||
@@ -6,22 +6,14 @@ LICENSE = "GPLv2" | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
7 | 7 | ||
8 | SRC_URI = "git://github.com/openSUSE/build-compare.git \ | 8 | SRC_URI = "git://github.com/openSUSE/build-compare.git \ |
9 | file://Rename-rpm-check.sh-to-pkg-diff.sh.patch;striplevel=1 \ | ||
10 | file://Ignore-DWARF-sections.patch;striplevel=1 \ | 9 | file://Ignore-DWARF-sections.patch;striplevel=1 \ |
11 | file://0001-Add-support-for-deb-and-ipk-packaging.patch \ | ||
12 | file://functions.sh-remove-space-at-head.patch \ | ||
13 | file://functions.sh-run-rpm-once-to-make-it-faster.patch \ | ||
14 | file://pkg-diff.sh-check-for-fifo-named-pipe.patch \ | ||
15 | file://pkg-diff.sh-check_single_file-return-at-once-when-sa.patch \ | ||
16 | file://pkg-diff.sh-remove-space-in-the-end-for-ftype.patch \ | ||
17 | file://functions.sh-improve-deb-and-ipk-checking.patch \ | ||
18 | " | 10 | " |
19 | 11 | ||
20 | # Date matches entry in build-compare.changes and date of SRCREV. | 12 | # Date matches entry in build-compare.changes and date of SRCREV. |
21 | # | 13 | # |
22 | SRCREV = "c5352c054c6ef15735da31b76d6d88620f4aff0a" | 14 | SRCREV = "4dfa207660776cae120afa4353aec7f1f2a998d2" |
23 | PE = "1" | 15 | PE = "1" |
24 | PV = "2015.02.10+git${SRCPV}" | 16 | PV = "2019.08.14+git${SRCPV}" |
25 | UPSTREAM_CHECK_COMMITS = "1" | 17 | UPSTREAM_CHECK_COMMITS = "1" |
26 | 18 | ||
27 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |