summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-01-20 18:25:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-21 12:52:53 +0000
commit0966a762496a9bed618af63a8a04c8e8ca64cd36 (patch)
tree9041f592115a8fbff0bfc26e57f06038b2436a55 /meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb
parent11929c1f5b176719897552ebddf5035278d65b52 (diff)
downloadpoky-0966a762496a9bed618af63a8a04c8e8ca64cd36.tar.gz
btrfs-tools: upgrade 5.4 -> 5.4.1
(From OE-Core rev: dff50014c78d216374c0d637d48da3f00a29ef8b) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb
new file mode 100644
index 0000000000..cdc971cf5d
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "3fc2326d3474a5e4df2449f5e3043f7298501334"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
20 "
21
22PACKAGECONFIG ??= "python"
23PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
24PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native"
25PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
26
27inherit autotools-brokensep pkgconfig manpages
28inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'distutils3-base', '', d)}
29
30CLEANBROKEN = "1"
31
32EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
33EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
34EXTRA_PYTHON_CFLAGS_class-native = ""
35EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
36EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
37
38do_configure_prepend() {
39 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
40 mkdir -p ${S}/config
41 cp -f $(automake --print-libdir)/install-sh ${S}/config/
42}
43
44S = "${WORKDIR}/git"
45
46do_install_append() {
47 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
48 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
49 fi
50}
51
52BBCLASSEXTEND = "native"