summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.17.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-17 17:38:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-24 11:52:26 +0100
commit1d1d96e75f33783cf593745497d34069b5f622cd (patch)
treeddc938a9ebcf5c986b787ae7718ceb8e07cfdb30 /meta/recipes-devtools/btrfs-tools/btrfs-tools_4.17.bb
parentc441b34e42b097ec6eeeeacacd7e95c36322b258 (diff)
downloadpoky-1d1d96e75f33783cf593745497d34069b5f622cd.tar.gz
btrfs-tools: upgrade 4.16.1 -> 4.17
(From OE-Core rev: 90755fd4ec0303bbf237520dc5237926f70bc3bf) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_4.17.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_4.17.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.17.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.17.bb
new file mode 100644
index 0000000000..a3690d612c
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.17.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "33d16ffc0d176ff4a217a0491378d20ad34e0a90"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Makefile-build-mktables-using-native-gcc.patch \
20 file://0001-Add-LDFLAGS-when-building-libbtrfsutil.so.patch \
21 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
22 "
23
24inherit autotools-brokensep pkgconfig manpages distutils3-base
25
26CLEANBROKEN = "1"
27
28PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
29EXTRA_OECONF = " --disable-zstd"
30EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
31
32do_configure_prepend() {
33 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
34 mkdir -p ${S}/config
35 cp -f $(automake --print-libdir)/install-sh ${S}/config/
36}
37
38S = "${WORKDIR}/git"
39
40do_install_append() {
41 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
42}
43
44BBCLASSEXTEND = "native"