summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.13.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-10-04 16:37:16 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-09 12:33:16 +0000
commit4c63d6935a4a4d19f09051a97b9d0e38c86359e8 (patch)
tree6ac1ff1138afc802887e37f5bd0d8c920f20014f /meta/recipes-devtools/btrfs-tools/btrfs-tools_4.13.2.bb
parentfa1a12a33ae5c73b83fc265012e8959e77f9df33 (diff)
downloadpoky-4c63d6935a4a4d19f09051a97b9d0e38c86359e8.tar.gz
btrfs-tools: update to 4.13.2
(From OE-Core rev: caf7310c93657af489096493f6cbad6439a7476c) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_4.13.2.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_4.13.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.13.2.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.13.2.bb
new file mode 100644
index 0000000000..43924d874d
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.13.2.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "37f1faef159ebcf91846e7126879b1a413cb29a5"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Makefile-build-mktables-using-native-gcc.patch \
20 file://0001-Fix-build-with-musl-missing-header-include-for-dev_t.patch \
21 "
22
23inherit autotools-brokensep pkgconfig manpages
24
25PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
26EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
27
28do_configure_prepend() {
29 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
30 mkdir -p ${S}/config
31 cp -f $(automake --print-libdir)/install-sh ${S}/config/
32}
33
34S = "${WORKDIR}/git"
35
36BBCLASSEXTEND = "native"