summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-08-07 16:10:42 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-13 09:27:38 +0100
commit9952b38de4002da66da677380ac86283f852ad22 (patch)
tree0b4dd29156fbc58a98d7fdcad25c2c084c6882c7 /meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb
parent62455dfb8aabd5106f6316ef3fc93fc4116da17c (diff)
downloadpoky-9952b38de4002da66da677380ac86283f852ad22.tar.gz
btrfs-tools: update to 4.12
Add a patch to force a native build for a helper binary (which is not installed or used outside of the build process). (From OE-Core rev: 35e3ed68fd25941e3d76e5a063299b1d1cee0e70) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb
new file mode 100644
index 0000000000..c3cc89c2b0
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "0607132c3200bcead1426e6dc685432008de95de"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Makefile-build-mktables-using-native-gcc.patch \
20 "
21
22inherit autotools-brokensep pkgconfig manpages
23
24PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
25EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
26
27do_configure_prepend() {
28 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
29 mkdir -p ${S}/config
30 cp -f $(automake --print-libdir)/install-sh ${S}/config/
31}
32
33S = "${WORKDIR}/git"
34
35BBCLASSEXTEND = "native"