summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_3.1.bb
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-05-07 16:11:44 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-08 22:56:45 +0100
commitd6b53084af4d2923fccd6d6c9b43721fb4f414fb (patch)
tree2e5f35022aa59100497563fe1d21e915a4b8cf68 /meta/recipes-devtools/bison/bison_3.1.bb
parent0a0ffb2ca8655bf0b1bd39ae8b141a548465e63c (diff)
downloadpoky-d6b53084af4d2923fccd6d6c9b43721fb4f414fb.tar.gz
bison: upgrade 3.0.4 -> 3.1
Remove patches applied upstream. (From OE-Core rev: 5890ed343981b600148a1b4f1bedaf1e55519c67) Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_3.1.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_3.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.1.bb b/meta/recipes-devtools/bison/bison_3.1.bb
new file mode 100644
index 0000000000..a743bfdb81
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_3.1.bb
@@ -0,0 +1,40 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://dont-depend-on-help2man.patch.patch \
14 file://add-with-bisonlocaledir.patch \
15"
16
17# No point in hardcoding path to m4, just use PATH
18EXTRA_OECONF += "M4=m4"
19
20SRC_URI[md5sum] = "db7e431785ad96870bfa570a15cab079"
21SRC_URI[sha256sum] = "7c2464ad6cb7b513b2c350a092d919327e1f63d12ff024836acbb504475da5c6"
22
23inherit autotools gettext texinfo
24
25# The automatic m4 path detection gets confused, so force the right value
26acpaths = "-I ${S}/m4"
27
28do_compile_prepend() {
29 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
30}
31
32do_install_append_class-native() {
33 create_wrapper ${D}/${bindir}/bison \
34 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
35}
36do_install_append_class-nativesdk() {
37 create_wrapper ${D}/${bindir}/bison \
38 BISON_PKGDATADIR=${datadir}/bison
39}
40BBCLASSEXTEND = "native nativesdk"