summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_2.7.1.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-05-07 11:44:34 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-12 09:37:28 +0100
commit37c284c16b90d07b362cb6b605ea392f6829f7e6 (patch)
tree229baadb06b9c146259ce95181477bdd44c87012 /meta/recipes-devtools/bison/bison_2.7.1.bb
parent097e35deb034f52574d33bfc92bf265331bba2f4 (diff)
downloadpoky-37c284c16b90d07b362cb6b605ea392f6829f7e6.tar.gz
bison: upgraded to 2.7.1
(From OE-Core rev: 9cad15c8bc14d7f371e518b443650d1380b16516) Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_2.7.1.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_2.7.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_2.7.1.bb b/meta/recipes-devtools/bison/bison_2.7.1.bb
new file mode 100644
index 0000000000..10bd8e3ebd
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_2.7.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)."
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://m4.patch \
14 file://dont-depend-on-help2man.patch \
15 "
16
17# No point in hardcoding path to m4, just use PATH
18EXTRA_OECONF += "M4=m4"
19
20SRC_URI = "${BASE_SRC_URI} \
21 file://fix_cross_manpage_building.patch \
22 "
23
24SRC_URI[md5sum] = "7be02eb973eccf388f1ae750fc09eed0"
25SRC_URI[sha256sum] = "b409adcbf245baadb68d2f66accf6fdca5e282cafec1b865f4b5e963ba8ea7fb"
26
27LDFLAGS_prepend_libc-uclibc = " -lrt "
28DEPENDS_class-native = "gettext-minimal-native"
29SRC_URI_class-native = "${BASE_SRC_URI}"
30
31inherit autotools gettext
32acpaths = "-I ${S}/m4"
33
34do_install_append_class-native() {
35 create_wrapper ${D}/${bindir}/bison \
36 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
37}
38BBCLASSEXTEND = "native nativesdk"