summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_2.5.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-05-23 15:40:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-06 15:58:39 +0100
commit90d5d3ca116fc4d0a6412fbb66282ec1c0996dd3 (patch)
treed43beb0e4d232db16f1ef16fc071d901daad3afe /meta/recipes-devtools/bison/bison_2.5.bb
parentd0c2307bca5e98c7ff7bbef9867cebce7b8aeafa (diff)
downloadpoky-90d5d3ca116fc4d0a6412fbb66282ec1c0996dd3.tar.gz
bison: upgrade from 2.4.3 to 2.5
This version of bison needs m4 1.4.16 or newer (From OE-Core rev: 8aa07da69f4966afda40d77b1e8b83749c5d1c28) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_2.5.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_2.5.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_2.5.bb b/meta/recipes-devtools/bison/bison_2.5.bb
new file mode 100644
index 0000000000..b81efab74e
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_2.5.bb
@@ -0,0 +1,37 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)."
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10PRIORITY = "optional"
11DEPENDS = "bison-native"
12
13PR = "r0"
14
15BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.gz \
16 file://m4.patch \
17 "
18
19SRC_URI = "${BASE_SRC_URI} \
20 file://fix_cross_manpage_building.patch "
21
22SRC_URI[md5sum] = "687e1dcd29452789d34eaeea4c25abe4"
23SRC_URI[sha256sum] = "722def46e4a19a5b7a579ef30db1965f86c37c1a20a5f0113743a2e4399f7c99"
24
25DEPENDS_virtclass-native = "gettext-native"
26SRC_URI_virtclass-native = "${BASE_SRC_URI}"
27
28inherit autotools gettext
29acpaths = "-I ${S}/m4"
30
31do_install_append_virtclass-native() {
32 create_wrapper ${D}/${bindir}/bison \
33 M4=${STAGING_BINDIR_NATIVE}/m4 \
34 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
35}
36#bison-native encodes the staging M4 path
37BBCLASSEXTEND = "native"