summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_2.3.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-03-15 06:37:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-17 00:18:17 +0000
commit9ee33a8c75844a7d76d17ee8a612c743ee8ba66c (patch)
treeb2329555f21a4a32873d5b277eb14b968697d5c6 /meta/recipes-devtools/bison/bison_2.3.bb
parentac9b83e208e112477b6bfe9bc8e19f3ca9e93deb (diff)
downloadpoky-9ee33a8c75844a7d76d17ee8a612c743ee8ba66c.tar.gz
bison: bring back GPLv2 version 2.3 of bison recipe
(From OE-Core rev: 10ea8ad9c9281e5ad6910742f4db54d4f69ef144) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_2.3.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_2.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_2.3.bb b/meta/recipes-devtools/bison/bison_2.3.bb
new file mode 100644
index 0000000000..08aaa6e06a
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_2.3.bb
@@ -0,0 +1,35 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)."
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9SECTION = "devel"
10PRIORITY = "optional"
11DEPENDS = "gettext bison-native"
12
13PR = "r0"
14
15BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.gz \
16 file://bison-2.3_m4.patch"
17
18SRC_URI = "${BASE_SRC_URI}"
19
20SRC_URI[md5sum] = "22327efdd5080e2b1acb6e560a04b43a"
21SRC_URI[sha256sum] = "52f78aa4761a74ceb7fdf770f3554dd84308c3b93c4255e3a5c17558ecda293e"
22
23DEPENDS_virtclass-native = "gettext-native"
24SRC_URI_virtclass-native = "${BASE_SRC_URI}"
25
26inherit autotools
27acpaths = "-I ${S}/m4"
28
29do_install_append_virtclass-native() {
30 create_wrapper ${D}/${bindir}/bison \
31 M4=${STAGING_BINDIR_NATIVE}/m4 \
32 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
33}
34#bison-native encodes the staging M4 path
35BBCLASSEXTEND = "native"