summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_2.3.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/bison/bison_2.3.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_2.3.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_2.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_2.3.bb b/meta/recipes-devtools/bison/bison_2.3.bb
new file mode 100644
index 0000000000..a135451162
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_2.3.bb
@@ -0,0 +1,39 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12PR = "r1"
13
14BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.gz \
15 file://bison-2.3_m4.patch"
16
17SRC_URI = "${BASE_SRC_URI}"
18
19SRC_URI[md5sum] = "22327efdd5080e2b1acb6e560a04b43a"
20SRC_URI[sha256sum] = "52f78aa4761a74ceb7fdf770f3554dd84308c3b93c4255e3a5c17558ecda293e"
21
22DEPENDS_class-native = "gettext-native"
23SRC_URI_class-native = "${BASE_SRC_URI}"
24
25inherit autotools gettext
26acpaths = "-I ${S}/m4"
27
28do_configure_prepend () {
29 rm -f ${S}/m4/*gl.m4
30 cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/runtime-po/
31}
32
33do_install_append_class-native() {
34 create_wrapper ${D}/${bindir}/bison \
35 M4=${STAGING_BINDIR_NATIVE}/m4 \
36 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
37}
38#bison-native encodes the staging M4 path
39BBCLASSEXTEND = "native"