summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/binutils/binutils_2.32.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-17 17:21:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-08 10:20:20 +0100
commit2a87971b2216f1f56671411ceb2158e749ecf743 (patch)
treeb01999a6bd0f1f6efab9c8b89bae6949303f6ed8 /meta/recipes-devtools/binutils/binutils_2.32.bb
parent55c1b0571d607df10e7143a280b96b32c3fdfdb2 (diff)
downloadpoky-2a87971b2216f1f56671411ceb2158e749ecf743.tar.gz
binutils: Fix relocation of ld.so.conf in nativesdk builds
We need binutils to look at our ld.so.conf file within the SDK to ensure we search the SDK's libdirs as well as those from the host system. There add a patch which passes in the directory to the code using a define, then add it to a section we relocate in a similar way to the way we relocate the gcc internal paths. This ensures that ld works correctly in our buildtools tarball. Standard sysroot relocation doesn't work since we're not in a sysroot, we want to use both the host system and SDK libs. (From OE-Core rev: f6c1089642934ad93056ef19a0888965486ee030) (From OE-Core rev: 09a2b16ac2bd1e3e415131e46315c851373aa7e0) (From OE-Core rev: d0b7811b0e8654cf83d1b0f8256c7941fc3d9c41) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/binutils/binutils_2.32.bb')
-rw-r--r--meta/recipes-devtools/binutils/binutils_2.32.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/binutils/binutils_2.32.bb b/meta/recipes-devtools/binutils/binutils_2.32.bb
index 51a9748906..3dcc837c78 100644
--- a/meta/recipes-devtools/binutils/binutils_2.32.bb
+++ b/meta/recipes-devtools/binutils/binutils_2.32.bb
@@ -46,4 +46,6 @@ do_install_class-native () {
46PACKAGE_BEFORE_PN += "libbfd" 46PACKAGE_BEFORE_PN += "libbfd"
47FILES_libbfd = "${libdir}/libbfd-*.so" 47FILES_libbfd = "${libdir}/libbfd-*.so"
48 48
49SRC_URI_append_class-nativesdk = "file://nativesdk-relocation.patch"
50
49BBCLASSEXTEND = "native nativesdk" 51BBCLASSEXTEND = "native nativesdk"