diff options
author | Armin Kuster <akuster@mvista.com> | 2017-11-11 13:32:56 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-01-03 09:26:37 +0000 |
commit | a255e82b7ddee852f3fc0a9c557a2d7d5c01feb9 (patch) | |
tree | a86f6946d1feb4c44de7e5810563b6b33b3bf292 /meta/recipes-devtools/binutils/binutils_2.29.1.bb | |
parent | 183be315b1381c342104465075590fbb99cbe3cc (diff) | |
download | poky-a255e82b7ddee852f3fc0a9c557a2d7d5c01feb9.tar.gz |
binutils: update to 2.29.1
update to 2.29.1 to fix the following missing CVEs:
CVE-2017-15939, CVE-2017-15938, CVE-2017-15225, CVE-2017-15025,
CVE-2017-15024, CVE-2017-15023, CVE-2017-15022, CVE-2017-15021,
CVE-2017-15020, CVE-2017-14974, CVE-2017-14940, CVE-2017-14939,
CVE-2017-14938, CVE-2017-14934, CVE-2017-14933, CVE-2017-14932,
CVE-2017-14930, CVE-2017-14745, CVE-2017-14729, CVE-2017-14529,
CVE-2017-14333, CVE-2017-14130, CVE-2017-14129, CVE-2017-14128,
CVE-2017-13757, CVE-2017-13716, CVE-2017-13710, CVE-2017-12967,
CVE-2017-12799, CVE-2017-12459, CVE-2017-12458, CVE-2017-12457,
CVE-2017-12456, CVE-2017-12455, CVE-2017-12454, CVE-2017-12453,
CVE-2017-12452, CVE-2017-12451, CVE-2017-12450, CVE-2017-12449,
CVE-2017-12448
see Changelogs for additional information
(From OE-Core rev: 53df200cb5edab04a7ab38b974f96281733fadb2)
Signed-off-by: Armin Kuster <akuster@mvista.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/binutils/binutils_2.29.1.bb')
-rw-r--r-- | meta/recipes-devtools/binutils/binutils_2.29.1.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/binutils/binutils_2.29.1.bb b/meta/recipes-devtools/binutils/binutils_2.29.1.bb new file mode 100644 index 0000000000..51a9748906 --- /dev/null +++ b/meta/recipes-devtools/binutils/binutils_2.29.1.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | require binutils.inc | ||
2 | require binutils-${PV}.inc | ||
3 | |||
4 | DEPENDS += "flex bison zlib" | ||
5 | |||
6 | EXTRA_OECONF += "--with-sysroot=/ \ | ||
7 | --enable-install-libbfd \ | ||
8 | --enable-install-libiberty \ | ||
9 | --enable-shared \ | ||
10 | --with-system-zlib \ | ||
11 | " | ||
12 | |||
13 | EXTRA_OEMAKE_append_libc-musl = "\ | ||
14 | gt_cv_func_gnugettext1_libc=yes \ | ||
15 | gt_cv_func_gnugettext2_libc=yes \ | ||
16 | " | ||
17 | EXTRA_OECONF_class-native = "--enable-targets=all \ | ||
18 | --enable-64-bit-bfd \ | ||
19 | --enable-install-libiberty \ | ||
20 | --enable-install-libbfd \ | ||
21 | --disable-werror" | ||
22 | |||
23 | do_install_class-native () { | ||
24 | autotools_do_install | ||
25 | |||
26 | # Install the libiberty header | ||
27 | install -d ${D}${includedir} | ||
28 | install -m 644 ${S}/include/ansidecl.h ${D}${includedir} | ||
29 | install -m 644 ${S}/include/libiberty.h ${D}${includedir} | ||
30 | |||
31 | # We only want libiberty, libbfd and libopcodes | ||
32 | rm -rf ${D}${bindir} | ||
33 | rm -rf ${D}${prefix}/${TARGET_SYS} | ||
34 | rm -rf ${D}${prefix}/lib/ldscripts | ||
35 | rm -rf ${D}${prefix}/share/info | ||
36 | rm -rf ${D}${prefix}/share/locale | ||
37 | rm -rf ${D}${prefix}/share/man | ||
38 | rmdir ${D}${prefix}/share || : | ||
39 | rmdir ${D}/${libdir}/gcc-lib || : | ||
40 | rmdir ${D}/${libdir}64/gcc-lib || : | ||
41 | rmdir ${D}/${libdir} || : | ||
42 | rmdir ${D}/${libdir}64 || : | ||
43 | } | ||
44 | |||
45 | # Split out libbfd-*.so so including perf doesn't include extra stuff | ||
46 | PACKAGE_BEFORE_PN += "libbfd" | ||
47 | FILES_libbfd = "${libdir}/libbfd-*.so" | ||
48 | |||
49 | BBCLASSEXTEND = "native nativesdk" | ||