summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.11.3.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-03-16 12:00:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-26 10:05:06 +0100
commit9f17530dcc82783ab039a34e92fc6f67487fd2dd (patch)
treee4593f07fbfd88d15b7e42602147fbced45ba2dd /meta/recipes-devtools/automake/automake_1.11.3.bb
parent54a6f8498eb3031437fd6f889787b4a2c7ce4924 (diff)
downloadpoky-9f17530dcc82783ab039a34e92fc6f67487fd2dd.tar.gz
automake: upgrade from 1.11.2 to 1.11.3
Removed already upstream patch: automake/automake_1.11.2_fix_for_pkglibexec_SCRIPTS.patch Rebased these patches to the newer code: automake/prefer-cpio-over-pax-for-ustar-archives.patch automake/python-libdir.patch Changed the tarball name from bz2 to gz, as the bz2 tar ball is not published for the 1.11.3 version. [RP: Fix python.m4 to preserve the tweaks that allow us to build python modules] (From OE-Core rev: 94bf72aeae035ffade75bd9343937888bbb09c82) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.11.3.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.11.3.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.11.3.bb b/meta/recipes-devtools/automake/automake_1.11.3.bb
new file mode 100644
index 0000000000..20087741ae
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.11.3.bb
@@ -0,0 +1,67 @@
1require automake.inc
2LICENSE="GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_virtclass-native = "autoconf-native"
5
6RDEPENDS_${PN} += "\
7 autoconf \
8 perl \
9 perl-module-bytes \
10 perl-module-constant \
11 perl-module-cwd \
12 perl-module-data-dumper \
13 perl-module-dynaloader \
14 perl-module-errno \
15 perl-module-exporter-heavy \
16 perl-module-file-basename \
17 perl-module-file-compare \
18 perl-module-file-copy \
19 perl-module-file-glob \
20 perl-module-file-spec-unix \
21 perl-module-file-stat \
22 perl-module-getopt-long \
23 perl-module-io \
24 perl-module-io-file \
25 perl-module-posix \
26 perl-module-strict \
27 perl-module-text-parsewords \
28 perl-module-vars "
29
30RDEPENDS_${PN}_virtclass-native = "autoconf-native perl-native-runtime"
31RDEPENDS_${PN}_virtclass-nativesdk = "autoconf-nativesdk"
32
33PATHFIXPATCH = "file://path_prog_fixes.patch"
34PATHFIXPATCH_virtclass-native = ""
35PATHFIXPATCH_virtclass-nativesdk = ""
36
37PERLPATH = "${bindir}/perl"
38PERLPATH_virtclass-native = "/usr/bin/perl"
39PERLPATH_virtclass-nativesdk = "/usr/bin/perl"
40
41SRC_URI += "${PATHFIXPATCH} \
42 file://prefer-cpio-over-pax-for-ustar-archives.patch \
43 file://python-libdir.patch \
44 file://py-compile-compile-only-optimized-byte-code.patch"
45
46
47SRC_URI[md5sum] = "93ecb319f0365cb801990b00f658d026"
48SRC_URI[sha256sum] = "921b5188057e57bdd9c0ba06e21d0b0ea7dafa61a9bd08a2b041215bcff12f55"
49
50PR = "r0"
51
52do_install () {
53 oe_runmake 'DESTDIR=${D}' install
54 install -d ${D}${datadir}
55
56 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
57 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
58 for i in aclocal aclocal-1.11 automake automake-1.11; do
59 if [ -f ${D}${bindir}/$i ]; then
60 sed -i -e '1s,#!.*perl,#! ${PERLPATH},' \
61 -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${PERLPATH} \1 exec ${PERLPATH} \2,' \
62 ${D}${bindir}/$i
63 fi
64 done
65}
66
67BBCLASSEXTEND = "native nativesdk"