summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.11.2.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-12-27 11:30:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:14:40 +0000
commit761acbb4fa3ec8bec8e099e544495280a950e1de (patch)
tree6894e3fc5f6a4728bcc47909ede398b0d1352963 /meta/recipes-devtools/automake/automake_1.11.2.bb
parent99e4a9ad7999bf63bac289d7fa4dc64f104e85ba (diff)
downloadpoky-761acbb4fa3ec8bec8e099e544495280a950e1de.tar.gz
automake: upgrade from 1.11.1 to 1.11.2
(From OE-Core rev: 2dffe02af05413d8438ddc28d542dc5d85ac105f) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.11.2.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.11.2.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.11.2.bb b/meta/recipes-devtools/automake/automake_1.11.2.bb
new file mode 100644
index 0000000000..b455edfe6f
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.11.2.bb
@@ -0,0 +1,49 @@
1require automake.inc
2LICENSE="GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_virtclass-native = "autoconf-native"
5
6RDEPENDS_automake += "\
7 autoconf \
8 perl \
9 perl-module-bytes \
10 perl-module-constant \
11 perl-module-cwd \
12 perl-module-data-dumper \
13 perl-module-dynaloader \
14 perl-module-errno \
15 perl-module-exporter-heavy \
16 perl-module-file-basename \
17 perl-module-file-compare \
18 perl-module-file-copy \
19 perl-module-file-glob \
20 perl-module-file-spec-unix \
21 perl-module-file-stat \
22 perl-module-getopt-long \
23 perl-module-io \
24 perl-module-io-file \
25 perl-module-posix \
26 perl-module-strict \
27 perl-module-text-parsewords \
28 perl-module-vars "
29
30RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
31
32PATHFIXPATCH = "file://path_prog_fixes.patch"
33PATHFIXPATCH_virtclass-native = ""
34PATHFIXPATCH_virtclass-nativesdk = ""
35
36SRC_URI += "${PATHFIXPATCH} \
37 file://prefer-cpio-over-pax-for-ustar-archives.patch \
38 file://python-libdir.patch"
39
40PR = "r0"
41SRC_URI[md5sum] = "18194e804d415767bae8f703c963d456"
42SRC_URI[sha256sum] = "4f46d1f9380c8a3506280750f630e9fc915cb1a435b724be56b499d016368718"
43
44do_install () {
45 oe_runmake 'DESTDIR=${D}' install
46 install -d ${D}${datadir}
47}
48
49BBCLASSEXTEND = "native nativesdk"