summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.18.5.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-08-05 14:08:57 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-11 09:28:51 -0700
commit6d8ace03d6c785b09d16d81c35c8b1c3ce53e8e2 (patch)
treee5489957d351a047a7acf122c1ef528f3defcb53 /meta/recipes-devtools/autogen/autogen-native_5.18.5.bb
parent9d32d93779638b47df7b087b20148a62bc62f64e (diff)
downloadpoky-6d8ace03d6c785b09d16d81c35c8b1c3ce53e8e2.tar.gz
autogen: update to 5.18.5
Also, drop guile.patch, because the same problem has been fixed differently in the new upstream release. (From OE-Core rev: 02e187e1f9fb79e4496b3f767ea763e1cf25f06f) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.18.5.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.5.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.5.bb
new file mode 100644
index 0000000000..2a2851283b
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.5.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Automated text and program generation tool"
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://increase-timeout-limit.patch \
13 file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch \
14 file://redirect-output-dir.patch \
15"
16
17SRC_URI[md5sum] = "385d7c7dfbe60babbee261c054923a53"
18SRC_URI[sha256sum] = "7bbdb73b5518baf64c6d3739fb2ecc66d2cccda888ce5ad573abe235ab5d96ba"
19
20DEPENDS = "guile-native libtool-native libxml2-native"
21
22inherit autotools texinfo native pkgconfig
23
24# autogen-native links against libguile which may have been relocated with sstate
25# these environment variables ensure there isn't a relocation issue
26export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
27export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
28
29do_install_append () {
30 create_wrapper ${D}/${bindir}/autogen \
31 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
32 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
33}