summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.18.4.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-11 19:10:56 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-23 11:36:25 +0000
commit4a0386ee7045fa82ee8cca5022d161610f529540 (patch)
tree271cf84104451f8e406da7f8fcfceb4c6819141e /meta/recipes-devtools/autogen/autogen-native_5.18.4.bb
parentcc0ee9b56c55516a058e157a91a86a84b6676683 (diff)
downloadpoky-4a0386ee7045fa82ee8cca5022d161610f529540.tar.gz
autogen-native: upgrade to 5.18.4
(From OE-Core rev: a7c6cf649641e1411ab4dd1921b2953361e4f6fd) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.18.4.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.4.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.4.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.4.bb
new file mode 100644
index 0000000000..302ba79f77
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.4.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Automated text and program generation tool"
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://guile.patch \
13 file://increase-timeout-limit.patch \
14 file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch"
15
16SRC_URI[md5sum] = "6f48029cc839303d28496e1609868938"
17SRC_URI[sha256sum] = "3cd9f81a8ae7c6865bb9bbbe16c4307a243a1373d0b315a83571cbba1fff725d"
18
19DEPENDS = "guile-native libtool-native libxml2-native"
20
21inherit autotools texinfo native pkgconfig
22
23# autogen-native links against libguile which may have been relocated with sstate
24# these environment variables ensure there isn't a relocation issue
25export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
26export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
27
28do_install_append () {
29 create_wrapper ${D}/${bindir}/autogen \
30 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
31 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
32}