diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2021-05-24 11:13:42 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-05-25 22:36:09 +0100 |
commit | d44269179a30b3b29f042dba5e7908323f6b88e4 (patch) | |
tree | 312b0155101af5bacef8254dd8b8560a423a354f /meta/recipes-devtools/apt/apt_2.2.3.bb | |
parent | dfae094307dcdcd067c47eaeaa37e91f2482d101 (diff) | |
download | poky-d44269179a30b3b29f042dba5e7908323f6b88e4.tar.gz |
apt: upgrade 2.2.2 -> 2.2.3
(From OE-Core rev: 78fb660b67488bdd7e29ca606c22d0a06c5a309f)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/apt/apt_2.2.3.bb')
-rw-r--r-- | meta/recipes-devtools/apt/apt_2.2.3.bb | 134 |
1 files changed, 134 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_2.2.3.bb b/meta/recipes-devtools/apt/apt_2.2.3.bb new file mode 100644 index 0000000000..ff9270c4b3 --- /dev/null +++ b/meta/recipes-devtools/apt/apt_2.2.3.bb | |||
@@ -0,0 +1,134 @@ | |||
1 | SUMMARY = "Advanced front-end for dpkg" | ||
2 | DESCRIPTION = "APT is the Advanced Package Tool, an advanced interface to the Debian packaging system which provides the apt-get program." | ||
3 | HOMEPAGE = "https://packages.debian.org/jessie/apt" | ||
4 | LICENSE = "GPLv2.0+" | ||
5 | SECTION = "base" | ||
6 | |||
7 | # Triehash script taken from https://github.com/julian-klode/triehash | ||
8 | SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/${BPN}_${PV}.tar.xz \ | ||
9 | file://triehash \ | ||
10 | file://0001-Disable-documentation-directory-altogether.patch \ | ||
11 | file://0001-Fix-musl-build.patch \ | ||
12 | file://0001-CMakeLists.txt-avoid-changing-install-paths-based-on.patch \ | ||
13 | file://0001-srvrec-Keep-support-for-older-resolver.patch \ | ||
14 | file://0001-cmake-Do-not-build-po-files.patch \ | ||
15 | file://0001-Hide-fstatat64-and-prlimit64-defines-on-musl.patch \ | ||
16 | " | ||
17 | |||
18 | SRC_URI_append_class-native = " \ | ||
19 | file://0001-Do-not-init-tables-from-dpkg-configuration.patch \ | ||
20 | file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \ | ||
21 | " | ||
22 | |||
23 | SRC_URI_append_class-nativesdk = " \ | ||
24 | file://0001-Do-not-init-tables-from-dpkg-configuration.patch \ | ||
25 | file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \ | ||
26 | " | ||
27 | |||
28 | SRC_URI[sha256sum] = "2880474bc08c79f103cd30d24a9c30c78b480c65076e466d24df93b9fa05ab27" | ||
29 | LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
30 | |||
31 | # the package is taken from snapshots.debian.org; that source is static and goes stale | ||
32 | # so we check the latest upstream from a directory that does get updated | ||
33 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/a/apt/" | ||
34 | |||
35 | inherit cmake perlnative bash-completion upstream-version-is-even useradd | ||
36 | |||
37 | # User is added to allow apt to drop privs, will runtime warn without | ||
38 | USERADD_PACKAGES = "${PN}" | ||
39 | USERADD_PARAM_${PN} = "--system --home /nonexistent --no-create-home _apt" | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | ||
42 | |||
43 | DEPENDS += "db gnutls lz4 zlib bzip2 xz libgcrypt xxhash" | ||
44 | |||
45 | EXTRA_OECMAKE_append = " -DCURRENT_VENDOR=debian -DWITH_DOC=False \ | ||
46 | -DDPKG_DATADIR=${datadir}/dpkg \ | ||
47 | -DTRIEHASH_EXECUTABLE=${WORKDIR}/triehash \ | ||
48 | -DCMAKE_DISABLE_FIND_PACKAGE_ZSTD=True \ | ||
49 | -DCMAKE_DISABLE_FIND_PACKAGE_SECCOMP=True \ | ||
50 | -DWITH_TESTS=False \ | ||
51 | " | ||
52 | |||
53 | do_configure_prepend () { | ||
54 | echo "set( CMAKE_FIND_ROOT_PATH_MODE_INCLUDE BOTH )" >> ${WORKDIR}/toolchain.cmake | ||
55 | |||
56 | } | ||
57 | |||
58 | # Unfortunately apt hardcodes this all over the place | ||
59 | FILES_${PN} += "${prefix}/lib/dpkg ${prefix}/lib/apt" | ||
60 | RDEPENDS_${PN} += "bash perl dpkg" | ||
61 | |||
62 | customize_apt_conf_sample() { | ||
63 | cat > ${D}${sysconfdir}/apt/apt.conf.sample << EOF | ||
64 | Dir "${STAGING_DIR_NATIVE}/" | ||
65 | { | ||
66 | State "var/lib/apt/" | ||
67 | { | ||
68 | Lists "#APTCONF#/lists/"; | ||
69 | status "#ROOTFS#/var/lib/dpkg/status"; | ||
70 | }; | ||
71 | Cache "var/cache/apt/" | ||
72 | { | ||
73 | Archives "archives/"; | ||
74 | pkgcache ""; | ||
75 | srcpkgcache ""; | ||
76 | }; | ||
77 | Bin "${STAGING_BINDIR_NATIVE}/" | ||
78 | { | ||
79 | methods "${STAGING_LIBDIR}/apt/methods/"; | ||
80 | gzip "/bin/gzip"; | ||
81 | dpkg "dpkg"; | ||
82 | dpkg-source "dpkg-source"; | ||
83 | dpkg-buildpackage "dpkg-buildpackage"; | ||
84 | apt-get "apt-get"; | ||
85 | apt-cache "apt-cache"; | ||
86 | }; | ||
87 | Etc "#APTCONF#" | ||
88 | { | ||
89 | Preferences "preferences"; | ||
90 | }; | ||
91 | Log "var/log/apt"; | ||
92 | }; | ||
93 | |||
94 | APT | ||
95 | { | ||
96 | Install-Recommends "true"; | ||
97 | Immediate-Configure "false"; | ||
98 | Architecture "i586"; | ||
99 | Get | ||
100 | { | ||
101 | Assume-Yes "true"; | ||
102 | }; | ||
103 | }; | ||
104 | |||
105 | Acquire | ||
106 | { | ||
107 | AllowInsecureRepositories "true"; | ||
108 | }; | ||
109 | |||
110 | DPkg::Options {"--root=#ROOTFS#";"--admindir=#ROOTFS#/var/lib/dpkg";"--force-all";"--no-debsig"}; | ||
111 | DPkg::Path ""; | ||
112 | EOF | ||
113 | } | ||
114 | |||
115 | do_install_append_class-native() { | ||
116 | customize_apt_conf_sample | ||
117 | } | ||
118 | |||
119 | do_install_append_class-nativesdk() { | ||
120 | customize_apt_conf_sample | ||
121 | } | ||
122 | |||
123 | |||
124 | do_install_append_class-target() { | ||
125 | #Write the correct apt-architecture to apt.conf | ||
126 | APT_CONF=${D}/etc/apt/apt.conf | ||
127 | echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF} | ||
128 | } | ||
129 | |||
130 | # Avoid non-reproducible -src package | ||
131 | do_install_append () { | ||
132 | sed -i -e "s,${B},,g" \ | ||
133 | ${B}/apt-pkg/tagfile-keys.cc | ||
134 | } | ||