summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt/apt_1.2.24.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2017-08-22 12:20:39 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-23 08:47:03 +0100
commit7004cb7288a373773d531a14e6643a335eba3db6 (patch)
tree657fbfcb5dfea12055fa309bf6ef985baf2985e7 /meta/recipes-devtools/apt/apt_1.2.24.bb
parentc9a29aa55d47b1c7cbbd8611a92a7383c3d01a3a (diff)
downloadpoky-7004cb7288a373773d531a14e6643a335eba3db6.tar.gz
apt: Upgrade to 1.2.24
Add new patches for enable builds on hosts that has GCC version minor than 5 because doesn't support std::array and std::put_time, those patches could be removed after get rid of Debian8 and Centos7 support. - gcc_4.x_Revert-avoid-changing-the-global-LC_TIME-for-Release.patch - gcc_4.x_Revert-use-de-localed-std-put_time-instead-rolling-o.patch - gcc_4.x_apt-pkg-contrib-strutl.cc-Include-array-header.patch The LIC_FILES_CHKSUM changed because the license file now has style changes in the text remains GPLv2+. The patch Revert-always-run-dpkg-configure-a-at-the-end-of-our was updated because now the precision fields use floating point numbers. (From OE-Core rev: da99ae14c3a5719b317ff71b8f778a7c987f6158) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/apt/apt_1.2.24.bb')
-rw-r--r--meta/recipes-devtools/apt/apt_1.2.24.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_1.2.24.bb b/meta/recipes-devtools/apt/apt_1.2.24.bb
new file mode 100644
index 0000000000..ae0bce933d
--- /dev/null
+++ b/meta/recipes-devtools/apt/apt_1.2.24.bb
@@ -0,0 +1,20 @@
1DEPENDS = "curl db zlib"
2RDEPENDS_${PN} = "dpkg bash debianutils"
3require apt.inc
4
5require apt-package.inc
6
7PACKAGECONFIG ??= "lzma"
8PACKAGECONFIG[lzma] = "ac_cv_lib_lzma_lzma_easy_encoder=yes,ac_cv_lib_lzma_lzma_easy_encoder=no,xz"
9PACKAGECONFIG[bz2] = "ac_cv_lib_bz2_BZ2_bzopen=yes,ac_cv_lib_bz2_BZ2_bzopen=no,bzip2"
10PACKAGECONFIG[lz4] = "ac_cv_lib_lz4_LZ4F_createCompressionContext=yes,ac_cv_lib_lz4_LZ4F_createCompressionContext=no,lz4"
11
12FILES_${PN} += "${bindir}/apt-key"
13apt-manpages += "doc/apt-key.8"
14
15do_install_append() {
16 #Write the correct apt-architecture to apt.conf
17 APT_CONF=${D}/etc/apt/apt.conf
18 echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
19 oe_libinstall -so -C bin libapt-private ${D}${libdir}/
20}