summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/zlib/zlib_1.2.11.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-03-26 12:02:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-22 00:31:48 +0100
commitfe415144db8eb00fbb407888c9c76b1fea2d8127 (patch)
tree68c03afe032d724e883c5c0ce6ff7f2ee0e7ab19 /meta/recipes-core/zlib/zlib_1.2.11.bb
parentf1add4b50ea371722eeae82b67522136a460d216 (diff)
downloadpoky-fe415144db8eb00fbb407888c9c76b1fea2d8127.tar.gz
zlib: clean up ptest
Instead of patching and sedding the makefile, just install test/example and execute it in run-ptest. example is the bulk of the test suite, as minimal as it is. (From OE-Core rev: 9088a78e78f70721b2aa6bdbdf055551d5bd0265) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/zlib/zlib_1.2.11.bb')
-rw-r--r--meta/recipes-core/zlib/zlib_1.2.11.bb16
1 files changed, 1 insertions, 15 deletions
diff --git a/meta/recipes-core/zlib/zlib_1.2.11.bb b/meta/recipes-core/zlib/zlib_1.2.11.bb
index 41ec29d95e..ef9431ae47 100644
--- a/meta/recipes-core/zlib/zlib_1.2.11.bb
+++ b/meta/recipes-core/zlib/zlib_1.2.11.bb
@@ -7,7 +7,6 @@ LICENSE = "Zlib"
7LIC_FILES_CHKSUM = "file://zlib.h;beginline=6;endline=23;md5=5377232268e952e9ef63bc555f7aa6c0" 7LIC_FILES_CHKSUM = "file://zlib.h;beginline=6;endline=23;md5=5377232268e952e9ef63bc555f7aa6c0"
8 8
9SRC_URI = "${SOURCEFORGE_MIRROR}/libpng/${BPN}/${PV}/${BPN}-${PV}.tar.xz \ 9SRC_URI = "${SOURCEFORGE_MIRROR}/libpng/${BPN}/${PV}/${BPN}-${PV}.tar.xz \
10 file://Makefile-runtests.patch \
11 file://ldflags-tests.patch \ 10 file://ldflags-tests.patch \
12 file://run-ptest \ 11 file://run-ptest \
13 " 12 "
@@ -30,25 +29,12 @@ do_compile() {
30 oe_runmake shared 29 oe_runmake shared
31} 30}
32 31
33do_compile_ptest() {
34 oe_runmake test
35}
36
37do_install() { 32do_install() {
38 oe_runmake DESTDIR=${D} install 33 oe_runmake DESTDIR=${D} install
39} 34}
40 35
41do_install_ptest() { 36do_install_ptest() {
42 install ${B}/Makefile ${D}${PTEST_PATH} 37 install ${B}/examplesh ${D}${PTEST_PATH}
43 install ${B}/example ${D}${PTEST_PATH}
44 install ${B}/minigzip ${D}${PTEST_PATH}
45 install ${B}/examplesh ${D}${PTEST_PATH}
46 install ${B}/minigzipsh ${D}${PTEST_PATH}
47
48 # Remove buildhost references...
49 sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
50 -e 's|${DEBUG_PREFIX_MAP}||g' \
51 ${D}${PTEST_PATH}/Makefile
52} 38}
53 39
54# Move zlib shared libraries for target builds to $base_libdir so the library 40# Move zlib shared libraries for target builds to $base_libdir so the library