summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/zlib/files/configure.ac
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-30 15:04:45 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-10 14:38:44 +0000
commita142cbd47eb78b4ea63459286d97ab5e769c7bdc (patch)
treeea9296d1fccd617a7257258064aaf5b89c4f9c55 /meta/recipes-core/zlib/files/configure.ac
parent65d296a235a7d2f2689c530c91557ed6263afc01 (diff)
downloadpoky-a142cbd47eb78b4ea63459286d97ab5e769c7bdc.tar.gz
zlib: Upgrade 1.2.5 -> 1.2.6
Dont use autotools, it really not so autoconf like. the configure script gets updated with every release of zlib and we overwrite that. Instead use the upstream provided configure copyright year was changed in zlib.h which caused change in LIC_FILE_CHECKSUM fix.inverted.LFS.logic.patch is already applied upstream so drop it Drop the configure.ac and Makefile.am scripts since we do not autoreconf anymore and do not inherit autotools anymore Bump PR for depending recipes so a rebuild it ensues so that they dont depend on .la anymore and add missing dependencies discovered during incremental build (From OE-Core rev: 50ad5230ea9e0982cdfda23fb9fcfccf89d28f29) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/zlib/files/configure.ac')
-rw-r--r--meta/recipes-core/zlib/files/configure.ac48
1 files changed, 0 insertions, 48 deletions
diff --git a/meta/recipes-core/zlib/files/configure.ac b/meta/recipes-core/zlib/files/configure.ac
deleted file mode 100644
index 4761b7ef28..0000000000
--- a/meta/recipes-core/zlib/files/configure.ac
+++ /dev/null
@@ -1,48 +0,0 @@
1AC_INIT(zlib,1.2.5)
2AC_CONFIG_SRCDIR(adler32.c)
3AM_INIT_AUTOMAKE(zlibs,1.2.5)
4
5AC_PREREQ([2.59])
6
7AC_PROG_CC([gcc])
8AC_PROG_LIBTOOL
9
10AC_HEADER_STDC
11
12zlib_save_CPPFLAGS=$CPPFLAGS
13CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
14AC_CHECK_TYPES(off64_t)
15CPPFLAGS=$zlib_save_CPPFLAGS
16
17AC_CACHE_CHECK([whether to enable -D_LARGEFILE64_SOURCE], [zlib_cv_use_lfs64], [
18 zlib_cv_use_lfs64=no
19 if test "$ac_cv_type_off64_t" = "yes"; then
20 zlib_cv_use_lfs64=yes
21 fi
22])
23
24if test "$zlib_cv_use_lfs64" = "yes"; then
25 CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
26
27 #APR_ADDTO(CPPFLAGS, [-D_LARGEFILE64_SOURCE])
28fi
29
30cat > zlibdefs.h << EOF
31/* zlibdefs.h -- compile-time definitions for the zlib compression library
32 * Copyright (C) 1995-2006 Jean-loup Gailly.
33 * For conditions of distribution and use, see copyright notice in zlib.h
34 */
35
36#include <sys/types.h> /* for off_t */
37#include <unistd.h> /* for SEEK_* and off_t */
38#ifdef VMS
39# include <unixio.h> /* for off_t */
40#endif
41#ifndef z_off_t
42# define z_off_t off_t
43#endif
44EOF
45
46AC_CONFIG_FILES([Makefile])
47
48AC_OUTPUT