summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux/util-linux_2.21.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-02-27 00:45:48 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-28 12:27:46 +0000
commit79e8d533eec5dc0b1831bd4c6e4959401c7f1fcb (patch)
tree6253b2390a781ad4e84a50108ca158b553890c4c /meta/recipes-core/util-linux/util-linux_2.21.bb
parentef461c4a2a3e056adc875662f3c26f2cb4b9f161 (diff)
downloadpoky-79e8d533eec5dc0b1831bd4c6e4959401c7f1fcb.tar.gz
util-linux: Update to 2.21
This updates various checksums for the COPYING files, which moved in the process no changes to Licenses Tweak the scanf_cv_alloc_modifier and rebase the patch (From OE-Core rev: 9cb35b41c803bd0d1904b2dc0e14624fa7ea6e95) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/util-linux/util-linux_2.21.bb')
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.21.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-core/util-linux/util-linux_2.21.bb b/meta/recipes-core/util-linux/util-linux_2.21.bb
new file mode 100644
index 0000000000..aa6ac649a3
--- /dev/null
+++ b/meta/recipes-core/util-linux/util-linux_2.21.bb
@@ -0,0 +1,47 @@
1MAJOR_VERSION = "2.21"
2PR = "r0"
3require util-linux.inc
4
5# note that `lscpu' is under GPLv3+
6LICENSE_util-linux-lscpu = "GPLv3+"
7
8SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
9 file://util-linux-ng-2.16-mount_lock_path.patch \
10 file://uclibc-__progname-conflict.patch \
11"
12
13SRC_URI[md5sum] = "3c7a26963f3921c1e775a80330321870"
14SRC_URI[sha256sum] = "2813ae6fe0449b60402e122c2baf97f26aa53e6e2dd05591c6cbcdf67ffdb6c6"
15
16# Only lscpu part is gplv3; rest of the code is not,
17# so take out the lscpu parts while running non-gplv3 build.
18python () {
19 d.setVar("REMOVELSCPU", "no")
20 if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1:
21 # avoid GPLv3
22 d.setVar("REMOVELSCPU", "yes")
23 packages = (d.getVar("PACKAGES", False) or "").split()
24 if "util-linux-lscpu" in packages:
25 packages.remove("util-linux-lscpu")
26 d.setVar("PACKAGES", " ".join(packages))
27
28 src_uri = (d.getVar("SRC_URI", False) or "").split()
29 src_uri.append("file://remove-lscpu.patch")
30 d.setVar("SRC_URI", " ".join(src_uri))
31}
32
33do_remove_lscpu() {
34 if [ "x${REMOVELSCPU}" = "xyes" ]; then
35 rm -f sys-utils/lscpu.c sys-utils/lscpu.1
36 rm -rf tests/ts/lscpu tests/expected/lscpu
37 fi
38}
39
40addtask remove_lscpu before do_configure after do_patch
41
42CACHED_CONFIGUREVARS += "scanf_cv_alloc_modifier=as"
43EXTRA_OECONF_virtclass-native += "--disable-fallocate --disable-use-tty-group"
44
45do_install_append () {
46 sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${bindir}/chkdupexe
47}