summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux/util-linux_2.20.1.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-12-01 14:45:39 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:14:30 +0000
commit0203b2b3af5858931fc82072551a264ec4506d52 (patch)
tree28946aa775299947330f4a02a100738ee7feaa64 /meta/recipes-core/util-linux/util-linux_2.20.1.bb
parent60a8f94c00101eff39428ff7548f45ffe1233103 (diff)
downloadpoky-0203b2b3af5858931fc82072551a264ec4506d52.tar.gz
util-linux: Update to 2.20.1
Add patch remove setting CC, LD and LDFLAGS on commandline since they are passed correctly via configure. Those setting also caused the configure information about -std=gnu99 from being passed correctly. Removed patch that was fixed upstream Added scanf configuration, since this is a cross-compile target check libuuid removed an API that e2fsprogs uuidd used (uuid__generate_*), thus we disable it in this patch and will now provide uuidd from util-linux. See http://sourceforge.net/projects/e2fsprogs/forums/forum/7053/topic/4639484 (From OE-Core rev: fdaf4e791fcacb48ea430ec768ad9a6919c65ce0) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/util-linux/util-linux_2.20.1.bb')
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.20.1.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-core/util-linux/util-linux_2.20.1.bb b/meta/recipes-core/util-linux/util-linux_2.20.1.bb
new file mode 100644
index 0000000000..a569131eab
--- /dev/null
+++ b/meta/recipes-core/util-linux/util-linux_2.20.1.bb
@@ -0,0 +1,49 @@
1MAJOR_VERSION = "2.20"
2PR = "r0"
3require util-linux.inc
4
5# note that `lscpu' is under GPLv3+
6LICENSE_util-linux-lscpu = "GPLv3+"
7
8SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
9 file://util-linux-ng-2.16-mount_lock_path.patch \
10 file://uclibc-__progname-conflict.patch \
11"
12
13SRC_URI[md5sum] = "079b37517fd4e002a2e6e992e8b4e361"
14SRC_URI[sha256sum] = "d16ebcda3e64ab88ed363d9c1242cdb7ccfd5e1f56c83d0c3b0638c23793bbe0"
15
16# Only lscpu part is gplv3; rest of the code is not,
17# so take out the lscpu parts while running non-gplv3 build.
18python () {
19 d.setVar("REMOVELSCPU", "no")
20 if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1:
21 # avoid GPLv3
22 d.setVar("REMOVELSCPU", "yes")
23 packages = (d.getVar("PACKAGES", False) or "").split()
24 if "util-linux-lscpu" in packages:
25 packages.remove("util-linux-lscpu")
26 d.setVar("PACKAGES", " ".join(packages))
27
28 src_uri = (d.getVar("SRC_URI", False) or "").split()
29 src_uri.append("file://remove-lscpu.patch")
30 d.setVar("SRC_URI", " ".join(src_uri))
31}
32
33do_remove_lscpu() {
34 if [ "x${REMOVELSCPU}" = "xyes" ]; then
35 rm -f sys-utils/lscpu.c sys-utils/lscpu.1
36 rm -rf tests/ts/lscpu tests/expected/lscpu
37 fi
38}
39
40addtask remove_lscpu before do_configure after do_patch
41
42# fallocate is glibc 2.10, fallocate64 is glibc 2.11
43# we need to disable it for older versions
44EXTRA_OECONF += "ac_cv_func_fallocate=no scanf_cv_type_modifier=as"
45EXTRA_OECONF_virtclass-native += "--disable-fallocate --disable-use-tty-group"
46
47do_install_append () {
48 sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${bindir}/chkdupexe
49}