summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux/util-linux_2.19.1.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-05-24 16:19:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-01 18:34:32 +0100
commita70cc536166de4114de1ad1c8f491f45093ef7fc (patch)
tree3050047ef7e4ba91d0788499da2b854770fa6322 /meta/recipes-core/util-linux/util-linux_2.19.1.bb
parent2dfc95b92d31540970891aea1aca0d9e04ba7df3 (diff)
downloadpoky-a70cc536166de4114de1ad1c8f491f45093ef7fc.tar.gz
util-linux: update to 2.19.1
(From OE-Core rev: 596e6807826c34a4f93d7cb26052d1bd7a985201) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/util-linux/util-linux_2.19.1.bb')
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.19.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-core/util-linux/util-linux_2.19.1.bb b/meta/recipes-core/util-linux/util-linux_2.19.1.bb
new file mode 100644
index 0000000000..7fe7497eb8
--- /dev/null
+++ b/meta/recipes-core/util-linux/util-linux_2.19.1.bb
@@ -0,0 +1,43 @@
1MAJOR_VERSION = "2.19"
2PR = "r0"
3require util-linux.inc
4
5# note that `lscpu' is under GPLv3+
6LICENSE_util-linux-lscpu = "GPLv3+"
7
8SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
9 file://util-linux-ng-2.16-mount_lock_path.patch"
10
11SRC_URI[md5sum] = "3eab06f05163dfa65479c44e5231932c"
12SRC_URI[sha256sum] = "d3eac4afcc687b3ae1ffedcab2dc12df84c7ba7045cce31386d2b7040a011c7d"
13
14# Only lscpu part is gplv3; rest of the code is not,
15# so take out the lscpu parts while running non-gplv3 build.
16python () {
17 d.setVar("REMOVELSCPU", "no")
18 if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1:
19 # avoid GPLv3
20 d.setVar("REMOVELSCPU", "yes")
21 packages = (d.getVar("PACKAGES", False) or "").split()
22 if "util-linux-lscpu" in packages:
23 packages.remove("util-linux-lscpu")
24 d.setVar("PACKAGES", " ".join(packages))
25
26 src_uri = (d.getVar("SRC_URI", False) or "").split()
27 src_uri.append("file://remove-lscpu.patch")
28 d.setVar("SRC_URI", " ".join(src_uri))
29}
30
31do_remove_lscpu() {
32 if [ "x${REMOVELSCPU}" = "xyes" ]; then
33 rm -f sys-utils/lscpu.c sys-utils/lscpu.1
34 rm -rf tests/ts/lscpu tests/expected/lscpu
35 fi
36}
37
38addtask remove_lscpu before do_configure after do_patch
39
40# fallocate is glibc 2.10, fallocate64 is glibc 2.11
41# we need to disable it for older versions
42EXTRA_OECONF += "ac_cv_func_fallocate=no"
43EXTRA_OECONF_virtclass-native += "--disable-fallocate --disable-use-tty-group"