summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/udev/udev_092.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-core/udev/udev_092.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/udev/udev_092.bb')
-rw-r--r--meta/recipes-core/udev/udev_092.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-core/udev/udev_092.bb b/meta/recipes-core/udev/udev_092.bb
new file mode 100644
index 0000000000..0e94d1f6c8
--- /dev/null
+++ b/meta/recipes-core/udev/udev_092.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
2/dev/, handles hotplug events and loads drivers at boot time. It replaces \
3the hotplug package and requires a kernel not older than 2.6.12."
4RPROVIDES_${PN} = "hotplug"
5
6PR = "r17"
7
8SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
9 file://noasmlinkage.patch;patch=1 \
10 file://flags.patch;patch=1 \
11 file://udevsynthesize.patch;patch=1 \
12 file://udevsynthesize.sh \
13 file://arm_inotify_fix.patch;patch=1 \
14 "
15
16SRC_URI_append_h2200 = " file://50-hostap_cs.rules "
17PACKAGE_ARCH_h2200 = "h2200"
18
19require udev.inc
20
21INITSCRIPT_PARAMS = "start 03 S ."
22
23FILES_${PN} += "${base_libdir}/udev/*"
24FILES_${PN}-dbg += "${base_libdir}/udev/.debug"
25UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/"
26EXTRA_OEMAKE += "libudevdir=/lib/udev libdir=${base_libdir} prefix="
27
28do_install () {
29 install -d ${D}${usrsbindir} \
30 ${D}${sbindir}
31 oe_runmake 'DESTDIR=${D}' INSTALL=install install
32 install -d ${D}${sysconfdir}/init.d
33 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/udev
34 install -m 0755 ${WORKDIR}/udev-cache ${D}${sysconfdir}/init.d/udev-cache
35
36 install -d ${D}${sysconfdir}/udev/rules.d/
37
38 install -m 0644 ${WORKDIR}/local.rules ${D}${sysconfdir}/udev/rules.d/local.rules
39 install -m 0644 ${WORKDIR}/permissions.rules ${D}${sysconfdir}/udev/rules.d/permissions.rules
40 install -m 0644 ${WORKDIR}/udev.rules ${D}${sysconfdir}/udev/rules.d/udev.rules
41 install -m 0644 ${WORKDIR}/links.conf ${D}${sysconfdir}/udev/links.conf
42 if [ "${UDEV_DEVFS_RULES}" = "1" ]; then
43 install -m 0644 ${WORKDIR}/devfs-udev.rules ${D}${sysconfdir}/udev/rules.d/devfs-udev.rules
44 fi
45
46 install -d ${D}${sysconfdir}/udev/scripts/
47
48 install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
49 install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts
50
51 install -d ${D}${base_libdir}/udev/
52 install -m 0755 ${S}/udevsynthesize ${D}${base_libdir}/udev/udevsynthesize
53 install -m 0755 ${WORKDIR}/udevsynthesize.sh ${D}${sbindir}/udevsynthesize
54}
55
56do_install_append_h2200() {
57 install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
58}