summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/uclibc/uclibc_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-06-30 01:07:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-30 23:42:15 +0100
commitc66a1d17f9a7a1170e95e7cff5856ee6c6f695c2 (patch)
tree493b6f588d61ecbc5d38879e66414485e13262ab /meta/recipes-core/uclibc/uclibc_git.bb
parent8781c843cf3e0913a8fdd2ff91935f051be01dd9 (diff)
downloadpoky-c66a1d17f9a7a1170e95e7cff5856ee6c6f695c2.tar.gz
uclibc: Fix bug exposed by udev 168+ for mips architecture
newer udev uses sgnalfd + epoll and this exposed a bug in uclibc for mips where SFD_NONBLOCK should be defined with 0200 for mips but was using 04000. This would cause random segfaults in udev during boot process Tested on qemumips/angstrom console-image since angstrom uses udev 171. It worked well when we did not use meta-oe layer because udev in oe-core will then be used which is at version 164. (From OE-Core rev: a318b3c319ab34f661b3f41855374adba5b10394) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/uclibc/uclibc_git.bb')
-rw-r--r--meta/recipes-core/uclibc/uclibc_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/uclibc/uclibc_git.bb b/meta/recipes-core/uclibc/uclibc_git.bb
index 201ec93f19..0e43f9e669 100644
--- a/meta/recipes-core/uclibc/uclibc_git.bb
+++ b/meta/recipes-core/uclibc/uclibc_git.bb
@@ -2,7 +2,7 @@ SRCREV="71d63ed75648da9b0b71afabb9c60aaad792c55c"
2 2
3require uclibc.inc 3require uclibc.inc
4PV = "0.9.31+0.9.32rc3" 4PV = "0.9.31+0.9.32rc3"
5PR = "${INC_PR}.4" 5PR = "${INC_PR}.5"
6PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc" 6PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
7 7
8FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/uclibc-git' ], d)}" 8FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/uclibc-git' ], d)}"
@@ -30,5 +30,6 @@ SRC_URI = "git://uclibc.org/uClibc.git;branch=master;protocol=git \
30 file://orign_path.patch \ 30 file://orign_path.patch \
31 file://rtld_no.patch \ 31 file://rtld_no.patch \
32 file://0001-Config.in.arch-Free-UCLIBC_HAS_FPU-setting-from-depe.patch \ 32 file://0001-Config.in.arch-Free-UCLIBC_HAS_FPU-setting-from-depe.patch \
33 file://0001-mips-signalfd.h-SFD_NONBLOCK-for-mips-is-0200-unlike.patch \
33 " 34 "
34S = "${WORKDIR}/git" 35S = "${WORKDIR}/git"