summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-13 14:34:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-13 22:38:06 +0100
commite112d46c9fdf4f2c834a6c50627767479a1da43c (patch)
tree0712b0038f8b84dc9dacd05bbe6f8061d0fc0a30 /meta/recipes-core/tasks/task-sdk-host-nativesdk.bb
parent05b59a64a38bf74e34aefd162128f022c7569470 (diff)
downloadpoky-e112d46c9fdf4f2c834a6c50627767479a1da43c.tar.gz
task-sdk-host: Add nativesdk to the task name so its clearer what the contents of the task represent
This is particularly important since the file doens't use BBCLASSEXTEND and PN is therefore misleading Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/tasks/task-sdk-host-nativesdk.bb')
-rw-r--r--meta/recipes-core/tasks/task-sdk-host-nativesdk.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb b/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb
new file mode 100644
index 0000000000..5ec40b140c
--- /dev/null
+++ b/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb
@@ -0,0 +1,33 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd
3#
4
5DESCRIPTION = "Host packages for the standalone SDK or external toolchain"
6PR = "r10"
7LICENSE = "MIT"
8ALLOW_EMPTY = "1"
9
10LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
11 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
12
13inherit nativesdk
14
15PACKAGES = "${PN}"
16
17RDEPENDS_${PN} = "\
18 pkgconfig-nativesdk \
19 qemu-nativesdk \
20 qemu-helper-nativesdk \
21 pseudo-nativesdk \
22 unfs-server-nativesdk \
23 opkg-nativesdk \
24 libtool-nativesdk \
25 "
26
27RDEPENDS_${PN}_darwin8 = "\
28 odcctools-cross-canadian \
29 llvm-cross-canadian \
30 pkgconfig-nativesdk \
31 opkg-nativesdk \
32 libtool-nativesdk \
33 "