summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-core-tools-debug.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-20 17:13:37 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-08 00:50:27 +0000
commit7215c25ec32f7e5e944192e52647cbc3622ac3ea (patch)
tree1939286df7ad2c68a61092ee5e2687b8fa899b77 /meta/recipes-core/tasks/task-core-tools-debug.bb
parent8df37ad54918e64f26e24144897831f443f167d6 (diff)
downloadpoky-7215c25ec32f7e5e944192e52647cbc3622ac3ea.tar.gz
task-core-tools: Divide it into 3 recipes
task-core-tools-debug, task-core-tools-profile, task-core-tools-testapps otherwise if we choose one through PACKAGE_GROUPS all packages are built since they are in same recipe. (From OE-Core rev: 180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/tasks/task-core-tools-debug.bb')
-rw-r--r--meta/recipes-core/tasks/task-core-tools-debug.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-core-tools-debug.bb b/meta/recipes-core/tasks/task-core-tools-debug.bb
new file mode 100644
index 0000000000..3c92f3f8f3
--- /dev/null
+++ b/meta/recipes-core/tasks/task-core-tools-debug.bb
@@ -0,0 +1,26 @@
1#
2# Copyright (C) 2008 OpenedHand Ltd.
3#
4
5DESCRIPTION = "Debug tools tasks for OE-Core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10PACKAGES = "\
11 ${PN} \
12 ${PN}-dbg \
13 ${PN}-dev \
14 "
15
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18ALLOW_EMPTY = "1"
19
20RDEPENDS_${PN} = "\
21 gdb \
22 gdbserver \
23 tcf-agent \
24 rsync \
25 strace \
26 "