summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_196.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-01-21 12:15:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-21 12:44:53 +0000
commit148bcc1124d9b0c06988576e2e17a92fea6655d0 (patch)
tree208a500792d4a08d2a5f072e282ca2530a05c920 /meta/recipes-core/systemd/systemd_196.bb
parenta5358511b1741e6abff1a8f5136f1c8662645fea (diff)
downloadpoky-148bcc1124d9b0c06988576e2e17a92fea6655d0.tar.gz
systemd: skip in non-systemd distros to fix world builds
(From OE-Core rev: a2553b5f8b80ca0cd578afa2d2857ebb2b70ee3c) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd_196.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_196.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_196.bb b/meta/recipes-core/systemd/systemd_196.bb
index 1861437236..85bb4f9884 100644
--- a/meta/recipes-core/systemd/systemd_196.bb
+++ b/meta/recipes-core/systemd/systemd_196.bb
@@ -247,3 +247,11 @@ update-alternatives --remove reboot ${base_bindir}/systemctl
247update-alternatives --remove shutdown ${base_bindir}/systemctl 247update-alternatives --remove shutdown ${base_bindir}/systemctl
248update-alternatives --remove poweroff ${base_bindir}/systemctl 248update-alternatives --remove poweroff ${base_bindir}/systemctl
249} 249}
250
251
252# As this recipe builds udev, respect the systemd DISTRO_FEATURE so we don't try
253# building udev and systemd in world builds.
254python () {
255 if not oe.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
256 raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
257}