summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-conf_242.bb
diff options
context:
space:
mode:
authorAndrej Valek <andrej.valek@siemens.com>2019-04-18 12:19:06 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-26 10:09:08 +0100
commitc814947e03943c305226f17686f34b0c62450680 (patch)
treef0000576030b9d1d3d0b3f61e57da3daf7f579cf /meta/recipes-core/systemd/systemd-conf_242.bb
parent018be19fbf50dc5d9be9aa1dad5f33023cec1595 (diff)
downloadpoky-c814947e03943c305226f17686f34b0c62450680.tar.gz
systemd: upgrade to 242
PATCH REBASED: ============== 0001-do-not-disable-buffer-in-writing-files.patch 0002-don-t-use-glibc-specific-qsort_r.patch 0003-missing_type.h-add-__compare_fn_t-and-comparison_fn_.patch 0004-add-fallback-parse_printf_format-implementation.patch 0005-rules-watch-metadata-changes-in-ide-devices.patch 0005-src-basic-missing.h-check-for-missing-strndupa.patch 0007-don-t-fail-if-GLOB_BRACE-and-GLOB_ALTDIRFUNC-is-not.patch 0009-socket-util-don-t-fail-if-libc-doesn-t-support-IDN.patch 0017-Do-not-disable-buffering-when-writing-to-oom_score_a.patch 0021-avoid-redefinition-of-prctl_mm_map-structure.patch 0024-test-json.c-define-M_PIl.patch PATCH DROPPED: ============== 0001-meson-declare-version.h-as-dep-for-various-targets-t.patch 0001-meson-declare-version.h-as-dependency-for-systemd.patch 0013-test-hexdecoct.c-Include-missing.h-for-strndupa.patch PATCH ADDED: 0025-fs-utilh-add-missing-sys-stat-include.patch (From OE-Core rev: 1d453c9087f92da1ceddc66a887941e4929b3448) Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd-conf_242.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-conf_242.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-conf_242.bb b/meta/recipes-core/systemd/systemd-conf_242.bb
new file mode 100644
index 0000000000..9bb27fd96d
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd-conf_242.bb
@@ -0,0 +1,53 @@
1require systemd.inc
2
3SUMMARY = "Systemd system configuration"
4DESCRIPTION = "Systemd may require slightly different configuration for \
5different machines. For example, qemu machines require a longer \
6DefaultTimeoutStartSec setting."
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10CONFFILES_${PN} = "${sysconfdir}/machine-id \
11${sysconfdir}/systemd/coredump.conf \
12${sysconfdir}/systemd/journald.conf \
13${sysconfdir}/systemd/logind.conf \
14${sysconfdir}/systemd/system.conf \
15${sysconfdir}/systemd/user.conf"
16
17FILES_${PN} = "${sysconfdir}/machine-id ${sysconfdir}/systemd"
18
19do_configure[noexec] = '1'
20do_compile[noexec] = '1'
21
22do_install() {
23 rm -rf ${D}/${sysconfdir}/systemd
24 install -d ${D}/${sysconfdir}/systemd
25
26 # Create machine-id
27 # 20:12 < mezcalero> koen: you have three options: a) run systemd-machine-id-setup at install time, b) have / read-only and an empty file there (for stateless) and c) boot with / writable
28 touch ${D}${sysconfdir}/machine-id
29
30 install -m 0644 ${S}/src/coredump/coredump.conf ${D}${sysconfdir}/systemd/coredump.conf
31
32 install -m 0644 ${S}/src/journal/journald.conf ${D}${sysconfdir}/systemd/journald.conf
33 # Enable journal to forward message to syslog daemon
34 sed -i -e 's/.*ForwardToSyslog.*/ForwardToSyslog=yes/' ${D}${sysconfdir}/systemd/journald.conf
35 # Set the maximium size of runtime journal to 64M as default
36 sed -i -e 's/.*RuntimeMaxUse.*/RuntimeMaxUse=64M/' ${D}${sysconfdir}/systemd/journald.conf
37
38 install -m 0644 ${S}/src/login/logind.conf.in ${D}${sysconfdir}/systemd/logind.conf
39 # Set KILL_USER_PROCESSES to yes
40 sed -i -e 's/@KILL_USER_PROCESSES@/yes/' ${D}${sysconfdir}/systemd/logind.conf
41
42 install -m 0644 ${S}/src/core/system.conf.in ${D}${sysconfdir}/systemd/system.conf
43 # Set MEMORY_ACCOUNTING_DEFAULT to yes
44 sed -i -e 's/@MEMORY_ACCOUNTING_DEFAULT@/yes/' ${D}${sysconfdir}/systemd/system.conf
45
46 install -m 0644 ${S}/src/core/user.conf ${D}${sysconfdir}/systemd/user.conf
47}
48
49# Based on change from YP bug 8141, OE commit 5196d7bacaef1076c361adaa2867be31759c1b52
50do_install_append_qemuall() {
51 # Change DefaultTimeoutStartSec from 90s to 240s
52 echo "DefaultTimeoutStartSec = 240s" >> ${D}${sysconfdir}/systemd/system.conf
53}