summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-boot_243.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-09-13 19:26:27 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-16 23:02:45 +0100
commit2e79c06beaa8605fcac6df65d902ee80c50e25c9 (patch)
treec917a431c342d5b5253b2273d295ab751a898673 /meta/recipes-core/systemd/systemd-boot_243.bb
parentd84e9f446a3e948f213182c3abfdaa168cc56c1f (diff)
downloadpoky-2e79c06beaa8605fcac6df65d902ee80c50e25c9.tar.gz
systemd: upgrade to 243
PATCH REBASED: ============== 0001-binfmt-Don-t-install-dependency-links-at-install-tim.patch 0001-do-not-disable-buffer-in-writing-files.patch 0002-use-lnr-wrapper-instead-of-looking-for-relative-opti.patch 0004-add-fallback-parse_printf_format-implementation.patch 0004-rules-whitelist-hd-devices.patch 0005-rules-watch-metadata-changes-in-ide-devices.patch 0005-src-basic-missing.h-check-for-missing-strndupa.patch 0006-Include-netinet-if_ether.h.patch 0007-don-t-fail-if-GLOB_BRACE-and-GLOB_ALTDIRFUNC-is-not.patch 0017-Do-not-disable-buffering-when-writing-to-oom_score_a.patch PATCH DROPPED: ============== 0001-Replace-the-legacy-ULONG_LONG_MAX-with-the-C99-ULLON.patch 0001-src-udev-udev-event.c-must-include-sys-wait.h.patch 0023-socket-util.h-include-string.h.patch 0025-fs-utilh-add-missing-sys-stat-include.patch PATCH ADDED: ============ 0002-src-login-brightness.c-include-sys-wait.h.patch 0003-src-basic-copy.c-include-signal.h.patch 0004-src-shared-cpu-set-util.h-add-__cpu_mask-definition.patch Also applied libc-glibc over-ride to pkg_postinst and pkg_prerm function definitions, as musl does not provide nsswitch.conf. (From OE-Core rev: cd735ab1df78f7d21b6bb18bdf4707aec68a0295) Signed-off-by: Scott Murray <scott.murray@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd-boot_243.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_243.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_243.bb b/meta/recipes-core/systemd/systemd-boot_243.bb
new file mode 100644
index 0000000000..56a25c35ba
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd-boot_243.bb
@@ -0,0 +1,73 @@
1require systemd.inc
2FILESEXTRAPATHS =. "${FILE_DIRNAME}/systemd:"
3
4DEPENDS = "intltool-native libcap util-linux gnu-efi gperf-native"
5
6# NOTE: These three patches are in theory not needed, but we haven't
7# figured out how to correctly pass efi-cc parameter if it's an array.
8SRC_URI += "file://0001-Revert-meson-use-an-array-option-for-efi-cc.patch \
9 file://0001-Revert-meson-print-EFI-CC-configuration-nicely.patch \
10 file://0001-Fix-to-run-efi_cc-and-efi_ld-correctly-when-cross-co.patch \
11 file://0001-meson-Add-Defi-objcopy-option-to-specify-objcopy.patch \
12 "
13
14inherit meson pkgconfig gettext
15inherit deploy
16
17EFI_CC ?= "${CC}"
18EXTRA_OEMESON += "-Defi=true \
19 -Dgnu-efi=true \
20 -Defi-includedir=${STAGING_INCDIR}/efi \
21 -Defi-ldsdir=${STAGING_LIBDIR} \
22 -Defi-libdir=${STAGING_LIBDIR} \
23 -Dman=false \
24 -Defi-cc='${EFI_CC}' \
25 -Defi-ld='${LD}' \
26 -Defi-objcopy='${OBJCOPY}' \
27 "
28
29# install to the image as boot*.efi if its the EFI_PROVIDER,
30# otherwise install as the full name.
31# This allows multiple bootloaders to coexist in a single image.
32python __anonymous () {
33 import re
34 target = d.getVar('TARGET_ARCH')
35 prefix = "" if d.getVar('EFI_PROVIDER') == "systemd-boot" else "systemd-"
36 if target == "x86_64":
37 systemdimage = prefix + "bootx64.efi"
38 else:
39 systemdimage = prefix + "bootia32.efi"
40 d.setVar("SYSTEMD_BOOT_IMAGE", systemdimage)
41 prefix = "systemd-" if prefix == "" else ""
42 d.setVar("SYSTEMD_BOOT_IMAGE_PREFIX", prefix)
43}
44
45FILES_${PN} = "/boot/EFI/BOOT/${SYSTEMD_BOOT_IMAGE}"
46
47RDEPENDS_${PN} += "virtual/systemd-bootconf"
48
49# Imported from the old gummiboot recipe
50TUNE_CCARGS_remove = "-mfpmath=sse"
51COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
52COMPATIBLE_HOST_x86-x32 = "null"
53
54do_compile() {
55 SYSTEMD_BOOT_EFI_ARCH="ia32"
56 if [ "${TARGET_ARCH}" = "x86_64" ]; then
57 SYSTEMD_BOOT_EFI_ARCH="x64"
58 fi
59
60 ninja src/boot/efi/${SYSTEMD_BOOT_IMAGE_PREFIX}${SYSTEMD_BOOT_IMAGE}
61}
62
63do_install() {
64 install -d ${D}/boot
65 install -d ${D}/boot/EFI
66 install -d ${D}/boot/EFI/BOOT
67 install ${B}/src/boot/efi/systemd-boot*.efi ${D}/boot/EFI/BOOT/${SYSTEMD_BOOT_IMAGE}
68}
69
70do_deploy () {
71 install ${B}/src/boot/efi/systemd-boot*.efi ${DEPLOYDIR}
72}
73addtask deploy before do_build after do_compile