summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash/psplash_git.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-08-25 11:20:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-02 18:15:29 +0100
commit99666e772dd50767295294a5686710e6e2a49851 (patch)
tree94af09055008a86accc352dc4fd65c82ad15c5f3 /meta/recipes-core/psplash/psplash_git.bb
parent06a89cb47da39fb9bb29e23cfb1751258391aeb2 (diff)
downloadpoky-99666e772dd50767295294a5686710e6e2a49851.tar.gz
o-hand recipes: convert from svn.o-hand.org to git.yoctoproject.org
(From OE-Core rev: 4e7218c19775ef81caed27742e9d203af10b7416) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/psplash/psplash_git.bb')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
new file mode 100644
index 0000000000..9112aa9168
--- /dev/null
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Userspace framebuffer boot logo based on usplash."
2DESCRIPTION = "PSplash is a userspace graphical boot splash screen for mainly embedded Linux devices supporting a 16bpp or 32bpp framebuffer. It has few dependencies (just libc), supports basic images and text and handles rotation. Its visual look is configurable by basic source changes. Also included is a 'client' command utility for sending information to psplash such as boot progress information."
3HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/psplash"
4SECTION = "base"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://psplash.h;md5=a87c39812c1e37f3451567cc29a29c8f"
7
8SRCREV = "e05374aae945bcfc6d962ed0d7b2774b77987e1d"
9PV = "0.1+git${SRCPV}"
10PR = "r0"
11
12SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
13 file://psplash-init \
14 file://psplash-poky-img.h"
15
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig update-rc.d
19
20FILES_${PN} += "/mnt/.psplash"
21
22do_configure_prepend () {
23 cp -f ${WORKDIR}/psplash-poky-img.h ${S}/
24}
25
26do_install_prepend() {
27 install -d ${D}/mnt/.psplash/
28 install -d ${D}${sysconfdir}/init.d/
29 install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
30}
31
32INITSCRIPT_NAME = "psplash.sh"
33INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."