summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash/psplash_git.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-03-26 22:16:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-27 13:16:23 +0000
commit860e758b7b7f27fbb47c645770593206c7453c1b (patch)
treeb0754fb958c51d1e8cdfe2902d2c0512ceca2dc7 /meta/recipes-core/psplash/psplash_git.bb
parentbdca49274173153b1b0a72887de6321b4756b684 (diff)
downloadpoky-1.4_M5.tar.gz
psplash_git.bb: fix do_compile by correcting the script path1.4_M5
The recent change in the builddir location is breaking this recipe as it is trying to run a script (make-image-header.sh) located in sourcedir from builddir. As the script does not gets to run, the resulting file is not generated causing error as seen below. This commit fixes the issue, by providing complete path of the script. This commit fixes this build error: ERROR: Error executing a python function in /srv/home/nitin/prj/poky.git/meta/recipes-core/psplash/psplash_git.bb: IOError: [Errno 2] No such file or directory: 'psplash-tlk-img.h' ERROR: Task 6 (/srv/home/nitin/prj/poky.git/meta/recipes-core/psplash/psplash_git.bb, do_compile) failed with exit code '1' (From OE-Core rev: c433a1b78c407bea17747cb77f5332ed8ee4c5e7) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/psplash/psplash_git.bb')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 5413b24057..2d0cae371d 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -74,12 +74,13 @@ python do_compile () {
74 import shutil, commands 74 import shutil, commands
75 75
76 # Build a separate executable for each splash image 76 # Build a separate executable for each splash image
77 convertscript = "%s/make-image-header.sh" % d.getVar('S', True)
77 destfile = "%s/psplash-poky-img.h" % d.getVar('S', True) 78 destfile = "%s/psplash-poky-img.h" % d.getVar('S', True)
78 localfiles = d.getVar('SPLASH_LOCALPATHS', True).split() 79 localfiles = d.getVar('SPLASH_LOCALPATHS', True).split()
79 outputfiles = d.getVar('SPLASH_INSTALL', True).split() 80 outputfiles = d.getVar('SPLASH_INSTALL', True).split()
80 for localfile, outputfile in zip(localfiles, outputfiles): 81 for localfile, outputfile in zip(localfiles, outputfiles):
81 if localfile.endswith(".png"): 82 if localfile.endswith(".png"):
82 outp = commands.getstatusoutput('./make-image-header.sh %s POKY' % localfile) 83 outp = commands.getstatusoutput('%s %s POKY' % (convertscript, localfile))
83 print(outp[1]) 84 print(outp[1])
84 fbase = os.path.splitext(os.path.basename(localfile))[0] 85 fbase = os.path.splitext(os.path.basename(localfile))[0]
85 shutil.copyfile("%s-img.h" % fbase, destfile) 86 shutil.copyfile("%s-img.h" % fbase, destfile)