summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb86
1 files changed, 86 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
new file mode 100644
index 0000000000..80f3031ff5
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
@@ -0,0 +1,86 @@
1#
2# Copyright (C) 2008 OpenedHand Ltd.
3#
4
5SUMMARY = "Profiling tools"
6LICENSE = "MIT"
7
8PR = "r3"
9
10inherit packagegroup
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14# For backwards compatibility after rename
15RPROVIDES_${PN} = "task-core-tools-profile"
16RREPLACES_${PN} = "task-core-tools-profile"
17RCONFLICTS_${PN} = "task-core-tools-profile"
18
19PROFILE_TOOLS_X = "${@base_contains('DISTRO_FEATURES', 'x11', 'sysprof', '', d)}"
20PROFILE_TOOLS_SYSTEMD = "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd-analyze', '', d)}"
21
22RRECOMMENDS_${PN} = "\
23 perf \
24 trace-cmd \
25 kernel-module-oprofile \
26 blktrace \
27 ${PROFILE_TOOLS_X} \
28 ${PROFILE_TOOLS_SYSTEMD} \
29 "
30
31PROFILETOOLS = "\
32 oprofile \
33 oprofileui-server \
34 powertop \
35 latencytop \
36 "
37
38# systemtap needs elfutils which is not fully buildable on uclibc
39# hence we exclude it from uclibc based builds
40SYSTEMTAP = "systemtap"
41SYSTEMTAP_libc-uclibc = ""
42SYSTEMTAP_mips = ""
43SYSTEMTAP_mips64 = ""
44SYSTEMTAP_aarch64 = ""
45
46# lttng-ust uses sched_getcpu() which is not there on uclibc
47# for some of the architectures it can be patched to call the
48# syscall directly but for x86_64 __NR_getcpu is a vsyscall
49# which means we can not use syscall() to call it. So we ignore
50# it for x86_64/uclibc
51
52LTTNGUST = "lttng-ust"
53LTTNGUST_libc-uclibc = ""
54LTTNGUST_aarch64 = ""
55
56LTTNGTOOLS = "lttng-tools"
57LTTNGTOOLS_aarch64 = ""
58
59LTTNGMODULES = "lttng-modules"
60LTTNGMODULES_aarch64 = ""
61LTTNGMODULES_arm = ""
62
63BABELTRACE = "babeltrace"
64BABELTRACE_aarch64 = ""
65
66# valgrind does not work on mips
67
68VALGRIND = "valgrind"
69VALGRIND_libc-uclibc = ""
70VALGRIND_mips = ""
71VALGRIND_mips64 = ""
72VALGRIND_arm = ""
73VALGRIND_aarch64 = ""
74
75# exmap-console
76# exmap-server
77
78RDEPENDS_${PN} = "\
79 ${PROFILETOOLS} \
80 ${LTTNGUST} \
81 ${LTTNGTOOLS} \
82 ${LTTNGMODULES} \
83 ${BABELTRACE} \
84 ${SYSTEMTAP} \
85 ${VALGRIND} \
86 "