summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-04 17:43:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 18:03:18 +0100
commit29c19460e242c37e2cd12577e5835829ffa16b98 (patch)
treee73dc8ddb7fef074dafd689377ef51a4d262bde5 /meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb
parent748e48249d1f7817f670d8d00ace34cbf2c11b29 (diff)
downloadpoky-29c19460e242c37e2cd12577e5835829ffa16b98.tar.gz
packagegroup-*: add RREPLACES/RCONFLICTS
These are needed to support upgrading from task-* to packagegroup-* within existing target images at runtime. Note: these settings will very likely be moved out to a separate inc file at some point in the future. (From OE-Core rev: 5dd4de086d744c81d2275077ad0e0022204b0a68) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb b/meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb
index 6af299521d..c8b5623bf5 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb
@@ -1,12 +1,16 @@
1DESCRIPTION = "Target packages for the standalone SDK" 1DESCRIPTION = "Target packages for the standalone SDK"
2PR = "r7" 2PR = "r8"
3LICENSE = "MIT" 3LICENSE = "MIT"
4 4
5inherit packagegroup 5inherit packagegroup
6 6
7# For backwards compatibility after rename 7# For backwards compatibility after rename
8RPROVIDES_${PN} = "task-core-standalone-sdk-target" 8RPROVIDES_${PN} = "task-core-standalone-sdk-target"
9RREPLACES_${PN} = "task-core-standalone-sdk-target"
10RCONFLICTS_${PN} = "task-core-standalone-sdk-target"
9RPROVIDES_${PN}-dbg = "task-core-standalone-sdk-target-dbg" 11RPROVIDES_${PN}-dbg = "task-core-standalone-sdk-target-dbg"
12RREPLACES_${PN}-dbg = "task-core-standalone-sdk-target-dbg"
13RCONFLICTS_${PN}-dbg = "task-core-standalone-sdk-target-dbg"
10 14
11RDEPENDS_${PN} = "\ 15RDEPENDS_${PN} = "\
12 libgcc \ 16 libgcc \