summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-04 17:43:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 18:03:18 +0100
commit29c19460e242c37e2cd12577e5835829ffa16b98 (patch)
treee73dc8ddb7fef074dafd689377ef51a4d262bde5 /meta/recipes-core/packagegroups/packagegroup-core-boot.bb
parent748e48249d1f7817f670d8d00ace34cbf2c11b29 (diff)
downloadpoky-29c19460e242c37e2cd12577e5835829ffa16b98.tar.gz
packagegroup-*: add RREPLACES/RCONFLICTS
These are needed to support upgrading from task-* to packagegroup-* within existing target images at runtime. Note: these settings will very likely be moved out to a separate inc file at some point in the future. (From OE-Core rev: 5dd4de086d744c81d2275077ad0e0022204b0a68) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-boot.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-boot.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
index d29dc2befe..16ad4e3ef8 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
@@ -6,7 +6,7 @@ SUMMARY = "Minimal boot requirements"
6DESCRIPTION = "The minimal set of packages required to boot the system" 6DESCRIPTION = "The minimal set of packages required to boot the system"
7LICENSE = "MIT" 7LICENSE = "MIT"
8DEPENDS = "virtual/kernel" 8DEPENDS = "virtual/kernel"
9PR = "r9" 9PR = "r10"
10 10
11inherit packagegroup 11inherit packagegroup
12 12
@@ -20,6 +20,8 @@ MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
20 20
21# For backwards compatibility after rename 21# For backwards compatibility after rename
22RPROVIDES_${PN} = "task-core-boot" 22RPROVIDES_${PN} = "task-core-boot"
23RREPLACES_${PN} = "task-core-boot"
24RCONFLICTS_${PN} = "task-core-boot"
23 25
24# Distro can override the following VIRTUAL-RUNTIME providers: 26# Distro can override the following VIRTUAL-RUNTIME providers:
25VIRTUAL-RUNTIME_dev_manager ?= "udev" 27VIRTUAL-RUNTIME_dev_manager ?= "udev"