summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-base.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 10:34:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 12:53:03 +0100
commit4a0bec427741946b7cf82d471508476a645930b9 (patch)
treea16192c3f39b48ca2d9755efb5f0cb894e996e75 /meta/recipes-core/packagegroups/packagegroup-base.bb
parent5f0c2e3509d154a724367c2a5de274baeae08af8 (diff)
downloadpoky-4a0bec427741946b7cf82d471508476a645930b9.tar.gz
packagegroup-*: add RPROVIDES for backwards compatibility
Allow references to the old task packages to continue to work. This does not add RPROVIDES for everything, just those packages that are likely to have been referred to. (From OE-Core rev: b41c45972a6d359f034615471959c84aee2bc456) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-base.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-base.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-base.bb b/meta/recipes-core/packagegroups/packagegroup-base.bb
index f151591f18..217830801d 100644
--- a/meta/recipes-core/packagegroups/packagegroup-base.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-base.bb
@@ -114,6 +114,15 @@ python __anonymous () {
114 114
115 if "3g" in distro_features and not "3g" in machine_features and ("pcmcia" in machine_features or "pci" in machine_features or "usbhost" in machine_features): 115 if "3g" in distro_features and not "3g" in machine_features and ("pcmcia" in machine_features or "pci" in machine_features or "usbhost" in machine_features):
116 d.setVar("ADD_3G", "packagegroup-base-3g") 116 d.setVar("ADD_3G", "packagegroup-base-3g")
117
118 # For backwards compatibility after rename
119 packages = d.getVar("PACKAGES", True).split()
120 packages.remove("packagegroup-distro-base")
121 packages.remove("packagegroup-machine-base")
122 for pkg in packages:
123 d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-base", "task-base"))
124 d.appendVar("RPROVIDES_packagegroup-distro-base", "task-distro-base")
125 d.appendVar("RPROVIDES_packagegroup-machine-base", "task-machine-base")
117} 126}
118 127
119# 128#