summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-29 11:38:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 12:52:55 +0100
commit272cb74d70686cb7f72005dc25e02f38b46ecd57 (patch)
tree3a5e4cb0c9a2e407b2d04c78b1eb51d0f429ca64 /meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
parentf1df3f828bfc9e70bf8cf5a7c2e2cf216944785a (diff)
downloadpoky-272cb74d70686cb7f72005dc25e02f38b46ecd57.tar.gz
Rename task to packagegroup
"Package group" is a much more appropriate name for these than task, since we use the word task to describe units of work executed by BitBake. (From OE-Core rev: 424dcf7046e4ad09dcc664eb1992201195247fcf) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb')
-rw-r--r--meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
new file mode 100644
index 0000000000..ea054bc9c9
--- /dev/null
+++ b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
@@ -0,0 +1,35 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd
3#
4
5DESCRIPTION = "Host packages for the standalone SDK or external toolchain"
6PR = "r11"
7LICENSE = "MIT"
8ALLOW_EMPTY = "1"
9
10LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
11 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
12
13inherit nativesdk
14
15PACKAGES = "${PN}"
16
17RDEPENDS_${PN} = "\
18 nativesdk-pkgconfig \
19 nativesdk-qemu \
20 nativesdk-qemu-helper \
21 nativesdk-pseudo \
22 nativesdk-unfs-server \
23 nativesdk-opkg \
24 nativesdk-libtool \
25 nativesdk-autoconf \
26 nativesdk-automake \
27 "
28
29RDEPENDS_${PN}_darwin8 = "\
30 odcctools-cross-canadian \
31 llvm-cross-canadian \
32 nativesdk-pkgconfig \
33 nativesdk-opkg \
34 nativesdk-libtool \
35 "