summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/newlib/newlib_3.0.0.bb
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandr@xilinx.com>2018-03-26 17:20:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 17:56:24 +0100
commitae5e33ddc48802af6288deacfee59bf5bf4b5223 (patch)
tree1c001161ac140e49c91a1d28d4e8618651ae9e44 /meta/recipes-core/newlib/newlib_3.0.0.bb
parentb6dbfabbadc3f980e8176f30f8cdf5cdb0775e3c (diff)
downloadpoky-ae5e33ddc48802af6288deacfee59bf5bf4b5223.tar.gz
newlib: Adds newlib and libgloss recipes
Newlib is a C library that is intended to be used on embedded systems. It is a conglomeration of several library parts, all under free software licenses that make them easily usable on embedded products. Newlib provides a C library alternative that can run on baremetal, mainly for resource constrained devices. Libgloss is the BSP part of the C library, which can be easily modified to port for new hardware platforms. (From OE-Core rev: fe490ff829440b94124317759d856e2e2daf5047) Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandr@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/newlib/newlib_3.0.0.bb')
-rw-r--r--meta/recipes-core/newlib/newlib_3.0.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-core/newlib/newlib_3.0.0.bb b/meta/recipes-core/newlib/newlib_3.0.0.bb
new file mode 100644
index 0000000000..3380576b83
--- /dev/null
+++ b/meta/recipes-core/newlib/newlib_3.0.0.bb
@@ -0,0 +1,16 @@
1require newlib.inc
2
3PROVIDES += "virtual/libc virtual/${TARGET_PREFIX}libc-for-gcc virtual/libiconv virtual/libintl"
4
5do_configure() {
6 ${S}/configure ${EXTRA_OECONF}
7}
8
9do_install_append() {
10 # Move include files and libs to default directories so they can be picked up later
11 mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
12 mv -v ${D}${prefix}/${TARGET_SYS}/include ${D}${includedir}
13
14 # Remove original directory
15 rmdir ${D}${prefix}/${TARGET_SYS}
16}