summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/newlib/libgloss_3.0.0.bb
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandr@xilinx.com>2018-03-26 17:20:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 17:56:24 +0100
commitae5e33ddc48802af6288deacfee59bf5bf4b5223 (patch)
tree1c001161ac140e49c91a1d28d4e8618651ae9e44 /meta/recipes-core/newlib/libgloss_3.0.0.bb
parentb6dbfabbadc3f980e8176f30f8cdf5cdb0775e3c (diff)
downloadpoky-ae5e33ddc48802af6288deacfee59bf5bf4b5223.tar.gz
newlib: Adds newlib and libgloss recipes
Newlib is a C library that is intended to be used on embedded systems. It is a conglomeration of several library parts, all under free software licenses that make them easily usable on embedded products. Newlib provides a C library alternative that can run on baremetal, mainly for resource constrained devices. Libgloss is the BSP part of the C library, which can be easily modified to port for new hardware platforms. (From OE-Core rev: fe490ff829440b94124317759d856e2e2daf5047) Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandr@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/newlib/libgloss_3.0.0.bb')
-rw-r--r--meta/recipes-core/newlib/libgloss_3.0.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/newlib/libgloss_3.0.0.bb b/meta/recipes-core/newlib/libgloss_3.0.0.bb
new file mode 100644
index 0000000000..664a922815
--- /dev/null
+++ b/meta/recipes-core/newlib/libgloss_3.0.0.bb
@@ -0,0 +1,32 @@
1require newlib.inc
2
3DEPENDS += "newlib"
4
5FILESEXTRAPATHS_prepend := "${THISDIR}/libgloss:"
6
7SRC_URI_append_powerpc = " file://fix-rs6000-crt0.patch"
8SRC_URI_append_arm = " file://fix_makefile_include_arm_h.patch"
9
10do_configure() {
11 ${S}/libgloss/configure ${EXTRA_OECONF}
12}
13
14do_install_prepend() {
15 # install doesn't create this itself, avoid install error
16 install -d ${D}${prefix}/${TARGET_SYS}/lib
17}
18
19do_install_append() {
20 # Move libs to default directories so they can be picked up later
21 mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
22
23 # Remove original directory
24 rmdir ${D}${prefix}/${TARGET_SYS}
25}
26
27# Split packages correctly
28FILES_${PN} += "${libdir}/*.ld ${libdir}/*.specs"
29FILES_${PN}-dev += "${libdir}/cpu-init/*"
30
31INHIBIT_PACKAGE_STRIP = "1"
32INHIBIT_PACKAGE_DEBUG_SPLIT = "1"