summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/netbase/netbase_4.41.bb
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-11-18 20:02:03 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 10:25:33 +0000
commita2ede09151032b5f5df584d085d599ed6bffb3e0 (patch)
tree2d14fb6e1037126e638d2d617d9553f0faba5b1b /meta/recipes-core/netbase/netbase_4.41.bb
parentd80c854c702be10c5f76e5647872bd8188506d22 (diff)
downloadpoky-a2ede09151032b5f5df584d085d599ed6bffb3e0.tar.gz
netbase: Upgrade to version 4.43
Fixed its metadata Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-core/netbase/netbase_4.41.bb')
-rw-r--r--meta/recipes-core/netbase/netbase_4.41.bb57
1 files changed, 0 insertions, 57 deletions
diff --git a/meta/recipes-core/netbase/netbase_4.41.bb b/meta/recipes-core/netbase/netbase_4.41.bb
deleted file mode 100644
index 585313b570..0000000000
--- a/meta/recipes-core/netbase/netbase_4.41.bb
+++ /dev/null
@@ -1,57 +0,0 @@
1SUMMARY = "Basic TCP/IP networking support"
2DESCRIPTION = "This package provides the necessary infrastructure for basic TCP/IP based networking"
3HOMEPAGE = "http://packages.debian.org/netbase"
4SECTION = "base"
5LICENSE = "GPLv2"
6PR = "r1"
7
8inherit update-rc.d
9
10INITSCRIPT_NAME = "networking"
11INITSCRIPT_PARAMS = "start 40 S . stop 40 0 6 1 ."
12# On MNCI etc, start very late so that our own apps come up faster
13INITSCRIPT_PARAMS_openmn = "start 85 1 2 3 4 5 . stop 85 0 6 1 ."
14# On SlugOS (NSLU2) delay the stop until after network apps have exited
15# Do not stop in single user - there's no way to sulogin!
16INITSCRIPT_PARAMS_slugos = "start 42 S 0 6 ."
17
18SRC_URI = "${DEBIAN_MIRROR}/main/n/netbase/netbase_${PV}.tar.gz \
19 file://init \
20 file://hosts \
21 file://interfaces \
22 file://nfsroot"
23
24do_install () {
25 install -d ${D}${sysconfdir}/init.d \
26 ${D}${sbindir} \
27 ${D}${mandir}/man8 \
28 ${D}${sysconfdir}/network/if-pre-up.d \
29 ${D}${sysconfdir}/network/if-up.d \
30 ${D}${sysconfdir}/network/if-down.d \
31 ${D}${sysconfdir}/network/if-post-down.d
32 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/networking
33 install -m 0644 ${WORKDIR}/hosts ${D}${sysconfdir}/hosts
34 install -m 0644 etc-rpc ${D}${sysconfdir}/rpc
35 install -m 0644 etc-protocols ${D}${sysconfdir}/protocols
36 install -m 0644 etc-services ${D}${sysconfdir}/services
37 install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
38 install -m 0755 ${WORKDIR}/nfsroot ${D}${sysconfdir}/network/if-pre-up.d
39
40 # Disable network manager on machines that commonly do NFS booting
41 case "${MACHINE}" in
42 "omap-3430sdp" | "omap-3430ldp" | "omap-2430sdp" | "qemuarm" | "qemux86" | "qemux86-64" )
43 touch ${D}${sysconfdir}/network/nm-disabled-eth0
44 ;;
45 *)
46 ;;
47 esac
48}
49
50CONFFILES_${PN} = "${sysconfdir}/hosts ${sysconfdir}/network/interfaces"
51
52PACKAGE_ARCH_omap-3430sdp = "${MACHINE_ARCH}"
53PACKAGE_ARCH_omap-3430ldp = "${MACHINE_ARCH}"
54PACKAGE_ARCH_omap-2430sdp = "${MACHINE_ARCH}"
55PACKAGE_ARCH_qemuarm = "${MACHINE_ARCH}"
56PACKAGE_ARCH_qemux86 = "${MACHINE_ARCH}"
57PACKAGE_ARCH_qemux86-64 = "${MACHINE_ARCH}"