summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/libucontext_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-11 22:21:04 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-14 16:33:59 +0000
commit7beff2f9427a00f5a1e344d1e65ad8e43865f8dc (patch)
treeb57858f6bf6f7796ba42d704508683d7f25e7e67 /meta/recipes-core/musl/libucontext_git.bb
parent6f3b5a8e24d7efbe7a5c66544998668ae0293d15 (diff)
downloadpoky-7beff2f9427a00f5a1e344d1e65ad8e43865f8dc.tar.gz
libucontext: Recognize ppc64le architecture
(From OE-Core rev: 03dec80604ae363c31a5f2b68eb3efdba7c35f1a) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl/libucontext_git.bb')
-rw-r--r--meta/recipes-core/musl/libucontext_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/musl/libucontext_git.bb b/meta/recipes-core/musl/libucontext_git.bb
index 734ad9c953..11affebb49 100644
--- a/meta/recipes-core/musl/libucontext_git.bb
+++ b/meta/recipes-core/musl/libucontext_git.bb
@@ -40,8 +40,8 @@ def map_kernel_arch(a, d):
40 elif re.match('aarch64_be_ilp32$', a): return 'aarch64' 40 elif re.match('aarch64_be_ilp32$', a): return 'aarch64'
41 elif re.match('mips(isa|)(32|)(r6|)(el|)$', a): return 'mips' 41 elif re.match('mips(isa|)(32|)(r6|)(el|)$', a): return 'mips'
42 elif re.match('mips(isa|)64(r6|)(el|)$', a): return 'mips64' 42 elif re.match('mips(isa|)64(r6|)(el|)$', a): return 'mips64'
43 elif re.match('p(pc64|owerpc64)(le)', a): return 'ppc64'
43 elif re.match('p(pc|owerpc)', a): return 'ppc' 44 elif re.match('p(pc|owerpc)', a): return 'ppc'
44 elif re.match('p(pc64|owerpc64)', a): return 'ppc64'
45 elif re.match('riscv64$', a): return 'riscv64' 45 elif re.match('riscv64$', a): return 'riscv64'
46 elif re.match('riscv32$', a): return 'riscv32' 46 elif re.match('riscv32$', a): return 'riscv32'
47 else: 47 else: