summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/libucontext_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-17 11:32:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-21 22:39:00 +0000
commit795bc2361653fa7e1e084b975056a6a4efe7f1d9 (patch)
treeeb5e98bac169216c5540f494602ebaf9ac031646 /meta/recipes-core/musl/libucontext_git.bb
parent2f6a47c4d4dc24135b69ed01e193740c24f269e8 (diff)
downloadpoky-795bc2361653fa7e1e084b975056a6a4efe7f1d9.tar.gz
libucontext: Fix multilib build
libdir is hardcoded to /lib which is not going to work in multilib scene, patch makefile to add a variable to override the libdir from env (From OE-Core rev: 75b29a68f11f9c10a89ba413abd1023cfcf90982) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl/libucontext_git.bb')
-rw-r--r--meta/recipes-core/musl/libucontext_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/musl/libucontext_git.bb b/meta/recipes-core/musl/libucontext_git.bb
index 72e15aa9a4..92cb703b0b 100644
--- a/meta/recipes-core/musl/libucontext_git.bb
+++ b/meta/recipes-core/musl/libucontext_git.bb
@@ -12,6 +12,7 @@ PV = "0.1.3+${SRCPV}"
12SRCREV = "e6b4d7516dae9b200e94fcfcb9ebc9331389655f" 12SRCREV = "e6b4d7516dae9b200e94fcfcb9ebc9331389655f"
13SRC_URI = "git://code.foxkit.us/adelie/libucontext.git;protocol=https \ 13SRC_URI = "git://code.foxkit.us/adelie/libucontext.git;protocol=https \
14 file://0001-pass-LDFLAGS-to-link-step.patch \ 14 file://0001-pass-LDFLAGS-to-link-step.patch \
15 file://0001-Makefile-Add-LIBDIR-variable.patch \
15" 16"
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
@@ -51,7 +52,7 @@ export ARCH = "${@map_kernel_arch(d.getVar('TARGET_ARCH'), d)}"
51 52
52CFLAGS += "-Iarch/${ARCH}" 53CFLAGS += "-Iarch/${ARCH}"
53 54
54EXTRA_OEMAKE = "CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'" 55EXTRA_OEMAKE = "CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}' LIBDIR='${base_libdir}'"
55 56
56do_compile() { 57do_compile() {
57 oe_runmake ARCH=${ARCH} 58 oe_runmake ARCH=${ARCH}