summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/libucontext_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-04-14 10:31:52 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-24 14:10:07 +0100
commit67622318092b2716603738b0b509b24ec457deaf (patch)
tree212661003b0cbc4944bd221dbe5e337e42a8309e /meta/recipes-core/musl/libucontext_git.bb
parent76b27d57a98d064491e80551671b64c2dd303ed9 (diff)
downloadpoky-67622318092b2716603738b0b509b24ec457deaf.tar.gz
libucontext: Bring in mips/mips64 support
License-Update: Updated copyright years [1] Latest master 0.10.x+ has added support for mips/mips64, which should help compile ruby on musl for these architectures Switch SRC_URI to github upstream URI Check for common arches before checking others in map_kernel_arch Drop already upstreamed patches [1] https://github.com/kaniini/libucontext/commit/d31eaabbaf5f45656c10e4bccd3fe6653a7d3ec1 (From OE-Core rev: aa3b25b649cfe5d30cc0d8a539fbbcc9efdb4fbd) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl/libucontext_git.bb')
-rw-r--r--meta/recipes-core/musl/libucontext_git.bb48
1 files changed, 24 insertions, 24 deletions
diff --git a/meta/recipes-core/musl/libucontext_git.bb b/meta/recipes-core/musl/libucontext_git.bb
index 92cb703b0b..ec988f1920 100644
--- a/meta/recipes-core/musl/libucontext_git.bb
+++ b/meta/recipes-core/musl/libucontext_git.bb
@@ -4,26 +4,25 @@
4SUMMARY = "ucontext implementation featuring glibc-compatible ABI" 4SUMMARY = "ucontext implementation featuring glibc-compatible ABI"
5HOMEPAGE = "https://github.com/kaniini/libucontext" 5HOMEPAGE = "https://github.com/kaniini/libucontext"
6LICENSE = "ISC" 6LICENSE = "ISC"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=864cc1445419406b7093e8e531c9515e" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=6eed01fa0e673c76f5a5715438f65b1d"
8SECTION = "libs" 8SECTION = "libs"
9DEPENDS = "" 9DEPENDS = ""
10 10
11PV = "0.1.3+${SRCPV}" 11PV = "0.10+${SRCPV}"
12SRCREV = "e6b4d7516dae9b200e94fcfcb9ebc9331389655f" 12SRCREV = "19fa1bbfc26efb92147b5e85cc0ca02a0e837561"
13SRC_URI = "git://code.foxkit.us/adelie/libucontext.git;protocol=https \ 13SRC_URI = "git://github.com/kaniini/libucontext \
14 file://0001-pass-LDFLAGS-to-link-step.patch \
15 file://0001-Makefile-Add-LIBDIR-variable.patch \
16" 14"
17 15
18S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
19 17
20COMPATIBLE_HOST = ".*-musl.*" 18COMPATIBLE_HOST = ".*-musl.*"
21 19
22valid_archs = "\ 20valid_archs = " \
23i386 x86 \ 21 x86 x86_64 \
24ppc powerpc powerpc64 ppc64 \ 22 ppc ppc64 \
25arm aarch64 \ 23 mips mips64 \
26s390 \ 24 arm aarch64 \
25 s390x \
27" 26"
28 27
29def map_kernel_arch(a, d): 28def map_kernel_arch(a, d):
@@ -31,18 +30,19 @@ def map_kernel_arch(a, d):
31 30
32 valid_archs = d.getVar('valid_archs').split() 31 valid_archs = d.getVar('valid_archs').split()
33 32
34 if re.match('(i.86|athlon)$', a): return 'x86' 33 if a in valid_archs: return a
35 elif re.match('x86.64$', a): return 'x86_64' 34 elif re.match('(i.86|athlon)$', a): return 'x86'
36 elif re.match('armeb$', a): return 'arm' 35 elif re.match('x86.64$', a): return 'x86_64'
37 elif re.match('aarch64$', a): return 'aarch64' 36 elif re.match('armeb$', a): return 'arm'
38 elif re.match('aarch64_be$', a): return 'aarch64' 37 elif re.match('aarch64$', a): return 'aarch64'
39 elif re.match('aarch64_ilp32$', a): return 'aarch64' 38 elif re.match('aarch64_be$', a): return 'aarch64'
40 elif re.match('aarch64_be_ilp32$', a): return 'aarch64' 39 elif re.match('aarch64_ilp32$', a): return 'aarch64'
41 elif re.match('mips(isa|)(32|64|)(r6|)(el|)$', a): return 'mips' 40 elif re.match('aarch64_be_ilp32$', a): return 'aarch64'
42 elif re.match('p(pc|owerpc)', a): return 'ppc' 41 elif re.match('mips(isa|)(32|)(r6|)(el|)$', a): return 'mips'
43 elif re.match('p(pc64|owerpc64)', a): return 'ppc64' 42 elif re.match('mips(isa|)64(r6|)(el|)$', a): return 'mips64'
44 elif re.match('riscv64$', a): return 'riscv64' 43 elif re.match('p(pc|owerpc)', a): return 'ppc'
45 elif a in valid_archs: return a 44 elif re.match('p(pc64|owerpc64)', a): return 'ppc64'
45 elif re.match('riscv64$', a): return 'riscv64'
46 else: 46 else:
47 if not d.getVar("TARGET_OS").startswith("linux"): 47 if not d.getVar("TARGET_OS").startswith("linux"):
48 return a 48 return a
@@ -50,7 +50,7 @@ def map_kernel_arch(a, d):
50 50
51export ARCH = "${@map_kernel_arch(d.getVar('TARGET_ARCH'), d)}" 51export ARCH = "${@map_kernel_arch(d.getVar('TARGET_ARCH'), d)}"
52 52
53CFLAGS += "-Iarch/${ARCH}" 53CFLAGS += "-Iarch/${ARCH} -Iarch/common"
54 54
55EXTRA_OEMAKE = "CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}' LIBDIR='${base_libdir}'" 55EXTRA_OEMAKE = "CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}' LIBDIR='${base_libdir}'"
56 56