summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/bsd-headers.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-03-02 09:52:53 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-04 11:35:42 +0000
commit43722946378242361680e326490568759b945e07 (patch)
tree71c81e30a970dc2ea55e4b086bf40a01d2ed787a /meta/recipes-core/musl/bsd-headers.bb
parentd7d3d341d24687c10b7bec234cea505865ded9cf (diff)
downloadpoky-43722946378242361680e326490568759b945e07.tar.gz
bsd-headers: Move next to musl recipes
This helps communicate the dependency a bit better (From OE-Core rev: 220d7451f65cb2e32a06503e36075889c63b0bd9) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl/bsd-headers.bb')
-rw-r--r--meta/recipes-core/musl/bsd-headers.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/bsd-headers.bb b/meta/recipes-core/musl/bsd-headers.bb
new file mode 100644
index 0000000000..c9945d45eb
--- /dev/null
+++ b/meta/recipes-core/musl/bsd-headers.bb
@@ -0,0 +1,31 @@
1# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "BSD compatible headers"
5LICENSE = "BSD-3-Clause & BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://sys-queue.h;beginline=1;endline=32;md5=c6352b0f03bb448600456547d334b56f"
7SECTION = "devel"
8
9SRC_URI = "file://sys-queue.h \
10 file://sys-tree.h \
11 file://sys-cdefs.h \
12 "
13do_configure[noexec] = "1"
14do_compile[noexec] = "1"
15
16INHIBIT_DEFAULT_DEPS = "1"
17
18S = "${WORKDIR}"
19
20do_install() {
21 install -Dm 0644 ${S}/sys-queue.h ${D}${includedir}/sys/queue.h
22 install -Dm 0644 ${S}/sys-tree.h ${D}${includedir}/sys/tree.h
23 install -Dm 0644 ${S}/sys-cdefs.h ${D}${includedir}/sys/cdefs.h
24}
25#
26# We will skip parsing for non-musl systems
27#
28
29COMPATIBLE_HOST = ".*-musl.*"
30RDEPENDS_${PN}-dev = ""
31RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"