summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/package-index.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-05-18 12:09:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-20 12:40:44 +0100
commit9fbd9b93aea780c8168f6de2692148b14dd9d6a7 (patch)
tree2a9aeccdcf807032bb309cd66dc35e6b320fd71b /meta/recipes-core/meta/package-index.bb
parent5956184bbe29fc24e1349035ec66cf57480fd63f (diff)
downloadpoky-9fbd9b93aea780c8168f6de2692148b14dd9d6a7.tar.gz
package-index.bb: add support for deb and rpm.
[YOCTO #1024] Currently package-index.bb only supports ipk. This commit adds the support for rpm and deb, too. ------------------------------ How to generate and use repos: 1) run "bitbake package-index" after building some target, e.g., core-image-sato-sdk; 2) export ${DEPLOY_DIR_RPM}, ${DEPLOY_DIR_IPK} and ${DEPLOY_DIR_DEB} by a webserver on the host, assuming the host IP is 192.168.7.1, at http://192.168.7.1/rpm http://192.168.7.1/ipk http://192.168.7.1/deb 3) inside the target, according to the packaging system (rpm, ipk or deb) used when we generate the target image, we can use different ways to manage packages: 3.1) RPM run "zypper addrepo http://192.168.7.1/rpm main; zypper refresh" to retrieve info about the repo; next, we can use "zypper install/remove" to manage packages. 3.2) IPK add the repo info into opkg config file, i.e., in /etc/opkg/arch.conf, we can add something like "src i586 http://192.168.7.1/ipk/i586", and next, we run "opkg update" to make opkg update the list of available packages. And later, we can use "opkg install/remove" to manage packages. 3.3) DEB Currently in target, some important config files, like /var/lib/dpkg/status and /etc/apt/sources.list, for deb/apt are missing. So we can't install/remove package in target at present. (From OE-Core rev: 01e34bdb43e0cc27c1cfffd6730c384f40c404c1) Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/package-index.bb')
-rw-r--r--meta/recipes-core/meta/package-index.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta/recipes-core/meta/package-index.bb b/meta/recipes-core/meta/package-index.bb
index 3c642cb571..bf3922f6d1 100644
--- a/meta/recipes-core/meta/package-index.bb
+++ b/meta/recipes-core/meta/package-index.bb
@@ -19,13 +19,11 @@ do_package_write_deb[noexec] = "1"
19do_populate_sysroot[noexec] = "1" 19do_populate_sysroot[noexec] = "1"
20 20
21do_package_index[nostamp] = "1" 21do_package_index[nostamp] = "1"
22do_package_index[dirs] = "${DEPLOY_DIR_IPK}" 22do_package_index[depends] += "${PACKAGEINDEXDEPS}"
23do_package_index[depends] += "opkg-utils-native:do_populate_sysroot"
24do_package_index[depends] += "opkg-native:do_populate_sysroot"
25 23
26do_package_index() { 24do_package_index() {
27 set -ex 25 set -ex
28 package_update_index_ipk 26 ${PACKAGEINDEXES}
29 set +ex 27 set +ex
30} 28}
31addtask do_package_index before do_build 29addtask do_package_index before do_build