summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-12-05 18:09:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-19 18:08:01 +0000
commita957ff1dc4d084f4b7868359a508241f4af480f4 (patch)
treef6175cd4e436234da988117b4336bd7b6e64a117 /meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
parentd5e0cc7b08e6960f17c65a9588b23022b22c0fcc (diff)
downloadpoky-a957ff1dc4d084f4b7868359a508241f4af480f4.tar.gz
buildtools-tarball: restore missing git tools
Since the split out of git-perltools, some git tools (such as "git am", "git send-email" and "git-submodule") have no longer been part of the buildtools. We need these, so add them back in. However, adding git-perltools to buildtools triggers perl itself being brought into buildtools as well, and we don't want that; but we also don't want to have to hack the git recipe or indeed anything else that starts depending on perl. Thus, add a dummy package which gets installed in its place, in a separate package architecture that is only enabled for buildtools to ensure it doesn't start appearing in place of nativesdk-perl anywhere else. Fixes [YOCTO #7033]. (From OE-Core rev: 5b051d65e797624cca3a81fc6f5c924925f3493e) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb')
-rw-r--r--meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
new file mode 100644
index 0000000000..d971c3ca3d
--- /dev/null
+++ b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Dummy package which ensures perl is excluded from buildtools"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5inherit nativesdk
6
7# Put it somewhere separate to ensure it's never used except when we want it
8PACKAGE_ARCH = "buildtools-dummy-${SDKPKGSUFFIX}"
9
10PERLPACKAGES = "nativesdk-perl \
11 nativesdk-perl-module-file-path"
12
13ALLOW_EMPTY_${PN} = "1"
14
15python populate_packages_prepend() {
16 d.appendVar('RPROVIDES_${PN}', '${PERLPACKAGES}')
17 d.appendVar('RCONFLICTS_${PN}', '${PERLPACKAGES}')
18}
19