summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-09 11:20:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-11 10:26:06 +0000
commit0d0984e1e616c9f1c211b7b980ba2ca54c096e6e (patch)
tree1dcc5055444c172a1f432c7e032f41027230ee8f /meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
parent1117f74385fe60d7eaeaef13ce5927e4798d6992 (diff)
downloadpoky-0d0984e1e616c9f1c211b7b980ba2ca54c096e6e.tar.gz
nativesdk/sdk: Update sdk dummy providers
When we migrated rpm v5 -> v4, we lost the ability to drop "per file" dependencies from the rpm backend for things like "/bin/bash" and "/usr/bin/env" which meant the sdks were becomming 'bloated'. This restores the functionality using a dummy package, similarly to the way the buildtools perl issue was addressed. It also removes the non-functional old code so as not to confuse people in future. I ran into this problem trying to filter dependencies to only rpms a build directly depends upon and it turns out we have some determinism issues in this area so this is something key to fix. (From OE-Core rev: 9d490dc01dcedb216129b22cbe17a6c99efc4f5c) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb')
-rw-r--r--meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb27
1 files changed, 6 insertions, 21 deletions
diff --git a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
index 0b58a027f3..f5bcb82548 100644
--- a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
+++ b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
@@ -1,26 +1,11 @@
1SUMMARY = "Dummy package which ensures perl is excluded from buildtools" 1DUMMYARCH = "buildtools-dummy-${SDKPKGSUFFIX}"
2LICENSE = "MIT"
3 2
4inherit allarch 3DUMMYPROVIDES = "\
4 nativesdk-perl \
5 nativesdk-perl-module-file-path"
5 6
6PR = "r2" 7PR = "r2"
7 8
8python() { 9require dummy-sdk-package.inc
9 # Put the package somewhere separate to ensure it's never used except
10 # when we want it
11 # (note that we have to do this in anonymous python here to avoid
12 # allarch.bbclass disabling itself)
13 d.setVar('PACKAGE_ARCH', 'buildtools-dummy-${SDKPKGSUFFIX}')
14}
15
16PERLPACKAGES = "nativesdk-perl \
17 nativesdk-perl-module-file-path"
18
19ALLOW_EMPTY_${PN} = "1"
20
21python populate_packages_prepend() {
22 d.appendVar(d.expand('RPROVIDES_${PN}'), '${PERLPACKAGES}')
23 d.appendVar(d.expand('RCONFLICTS_${PN}'), '${PERLPACKAGES}')
24 d.appendVar(d.expand('RREPLACES_${PN}'), '${PERLPACKAGES}')
25}
26 10
11inherit nativesdk