summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-12-05 18:09:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-06 14:13:37 +0000
commit2658acef69a0665e4d77f1b08cafb032749d9ee6 (patch)
treec6921d76efd8287918ee2e24115d2a3b0bd68a42 /meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
parentf20e4c0cf6ddb29a1aad6e7b095e1472e81d330c (diff)
downloadpoky-2658acef69a0665e4d77f1b08cafb032749d9ee6.tar.gz
buildtools-tarball: restore missing git tools
Since the split out of git-perltools, some git tools (such as "git am", "git send-email" and "git-submodule") have no longer been part of the buildtools. We need these, so add them back in. However, adding git-perltools to buildtools triggers perl itself being brought into buildtools as well, and we don't want that; but we also don't want to have to hack the git recipe or indeed anything else that starts depending on perl. Thus, add a dummy package which gets installed in its place, in a separate package architecture that is only enabled for buildtools to ensure it doesn't start appearing in place of nativesdk-perl anywhere else. Fixes [YOCTO #7033]. (From OE-Core rev: 5b051d65e797624cca3a81fc6f5c924925f3493e) (From OE-Core rev: 1f7651763e48d5d3d661987997dc6edae17a8718) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb')
-rw-r--r--meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
new file mode 100644
index 0000000000..a3cf9d754a
--- /dev/null
+++ b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Dummy package which ensures perl is excluded from buildtools"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5inherit nativesdk
6
7# Put it somewhere separate to ensure it's never used except when we want it
8PACKAGE_ARCH = "buildtools-dummy-${SDKPKGSUFFIX}"
9
10PERLPACKAGES = "nativesdk-perl \
11 nativesdk-perl-module-file-path"
12
13ALLOW_EMPTY_${PN} = "1"
14
15python populate_packages_prepend() {
16 d.appendVar('RPROVIDES_${PN}', '${PERLPACKAGES}')
17 d.appendVar('RCONFLICTS_${PN}', '${PERLPACKAGES}')
18}